Tool change with slicer stopped working....?



  • Hey there,
    I've been using tool changes via my slicer - simplify3d. it worked fine, been changing between T0/T1/T2 etc.

    Nor sure what happened but now it seems that the tool change with the slicer has stopped working and I'm changing the tool "manually" by selecting it from my tools on the duet web control.

    I used the same slicing file I always use and it stopped working.. Am I missing something maybe?

    duet 2, rrf 2.05. any thoughts?

    here's a piece from the gcode I'm running, I skipped to the parts with the tool changing:

    ; G-Code generated by Simplify3D(R) Version 4.1.2
    ; Mar 25, 2020 at 9:22:16 AM

    G90
    M82
    M107
    M140 S60
    M104 S0 T0
    ; process T2
    ; layer 1, Z = 1.700
    M108 T2
    G92 E0.0000
    G1 E-5.0000 F1200
    ; feature skirt
    ; tool H1.700 W2.200
    G1 Z4.000 F1002
    G1 X18.672 Y204.553 F4800
    G1 Z1.700 F1002
    G1 X25.738 Y215.153 E82.9620
    G1 X25.773 Y215.553 E83.3707
    G92 E0.0000
    G1 E-12.0000 F600
    ; process T4
    M108 T4
    ; feature external single extrusion
    ; tool H1.700 W1.184
    G1 Z7.400 F1002
    G1 X26.110 Y218.253 F4800
    G1 Z3.400 F1002

    thanks!



  • M108 is "cancel heating". It may or may not be needed... but... that gcode is certainly missing the actual tool commands. Which are just "T" and a number.

    Here is a piece of gcode that works:

    T0
    ;BEFORE_LAYER_CHANGE
    G92 E0.0
    ;0.3
    G1 E-2.00000 F2400.00000
    M73 P0 R606
    G1 Z0.300 F7800.000
    ;AFTER_LAYER_CHANGE
    ;0.3
    G1 X123.847 Y112.481
    G1 E2.00000 F2400.00000
    G1 F1800
    G1 X126.618 Y111.154 E0.14773
    G1 X129.349 Y110.131 E0.14028
    ... many lines removed ...
    G1 F1800
    G1 X200.136 Y142.200 E0.24773
    G1 F6240
    G1 X203.765 Y145.829 E-1.87533
    G1 E-8.12467 F2400.00000
    T1
    G1 E-2.00000
    G1 X163.613 Y178.698 F7800.000
    G1 E2.00000 F2400.00000
    G1 F1800
    G1 X164.436 Y179.878 E0.06918
    G1 X165.084 Y180.987 E0.06177
    G1 X165.587 Y182.005 E0.05462



  • So something changed in your Simplify3D Profile(s).



  • M108 yeah I know. but I always there even when gcode worked. I'll take it off and see.



  • @CJ-BRAVO @Danal

    ok it seems that M108 did screw up the tool change... very weird.

    I took it off and tool change works.

    thanks!


Log in to reply