Curious problem



  • Hello All

    how to best explain....

    So recently my printer started misbehaving on homing z.

    when i hit home z it starts homing, but for some strange reason the z axis stops about 0.5 above where 0 should be. I now literally scrapped all the files on the SD card and deployed it all from scratch. Its causing me to get inconstant levels when i was homing z. I have removed the z-probe and now only have end stops (low end) configured. Printer still stopping @ what it thinks is 0 and not even triggering the end stop by about 0.5mm.

    Is there a way to clear any settings on the board and resetting it to factory defaults. I want to get the end stops working again, the probe has been problematic.

    My Config now.
    ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Tue Mar 31 2020 16:00:10 GMT+0100 (British Summer Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"My Printer" ; set printer name

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S1 ; physical drive 2 goes forwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E1222.00 ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00 ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X230 Y210 Z200 S0 ; set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 S1 ; set active high endstops

    ; Z-Probe
    M558 P0 H5 F120 T6000 ; disable Z probe but set dive height, probe speed and travel speed
    M557 X15:215 Y15:195 S20 ; define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S1 I0 F500 H1 T45 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P1 S1 I0 F500 H1 T150 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined



  • @Shaun said in Curious problem:

    Is there a way to clear any settings on the board and resetting it to factory defaults.

    No settings are kept, ever, in the base board (the WiFi module does keep SSIDs and Passwords, but that's it). Power on runs config.g and all those commands take effect at the moment they are run.



  • Is the Z home switch at the physcial part of travel that is nearest zero? Does it click the switch before it stops?

    Also, bring up the "Machine Specific" panel and find the subpanel that shows the endstop status. Do you see correct changes when you click and unclick the z-stop switch with your finger?


  • Moderator

    @Shaun Please post your homeall.g file, and the other home[axis].g files if used.

    Ian



  • Think i resolved the problem, replaced the Z motor and seems to be working fine now. Recon its time for complete motor replacement from e3d.

    Thanks for the help guys.


Log in to reply