Possible Bug with M581 S-1



  • So I have this in the config.g

    M581 X1 Y1 Z1 S1 T2 C0 ; Emergency stop

    and this in the top of my homeall.g

    M581 S-1 ; Disable emergency stop

    and this in trigger2.g

    M300 S300 P1000 ; Sound the buzzer
    M117 Emergency stop activated because endstop was hit
    M112 ; Emergency stop

    But some reason M581 S-1 is ignored and so the homing sequence triggers an emergency stop anyways, I tried M581 X1 Y1 Z1 S-1 but same result



  • Not sure but I think you have to assign a trigger number as well as S-1 in the M581 to tell it which trigger to ignore. No doubt David will be along soon to confirm or otherwise.


  • administrators

    Ian is right, you must always specify the T parameter in any M581 or M582 command.



  • @dc42:

    Ian is right, you must always specify the T parameter in any M581 or M582 command.

    Thank you, I will update the wiki as it just says M581 S-1 with no other arguments


Log in to reply