G10 Tool Offset (Z) not working



  • So I have two tools defined in my config.g and up until recently had only been utilizing one of the tools. Now that I'm attempting to use the other tool and can't get the Z-offset to align. I have tried to change the Z offset in both directions and shows no change in the height of the second tool offset from the first tool.

    Board: Duet WiFi 1.02 or later + DueX5
    Firmware: RepRapFirmware for Duet 2 WiFi/Ethernet 3.0 (2020-01-03b3)
    Duet WiFi Server Version: 1.23

    ;;;;;;;;;;;;;;;;;
    ;;;   Tools   ;;;
    ;;;;;;;;;;;;;;;;;
    ;; Tool 0 - Extruder 0 - Chimera Head 1 - Mounted on Petsfang Chimera with custom TronXY Offset.
    M563 P0 D0 H1 F0                          ; Define tool 0 -> Heater 1 -> Fan 0
    G10 P0 R0 S0 X0 Y-13 Z0                         ; Set tool 0 axis offsets
    
    ;; Tool 1 - Extruder 1 - Chimera Head 2 - Mounted on Petsfang Chimera with custom TronXY Offset.
    M563 P1 D1 H2 F0                           ; Define tool 1 -> Heater 2 - Fan 0
    G10 P1 R0 S0 X17.6 Y-12.8 Z0.2                  ; Set tool 1 axis offsets
    
    T0                                        ; Select the first tool.
    

    Any suggestions? Anyone else having this problem?



  • Does anyone have any ideas? I was looking through my G-Code output and not seeing anything that would silently set the offset. It was working in the last version of 2.x I was running, but this is the first time since upgrading to the 3.x that I've tried printing with both heads simultaneous.

    I could try dialing the heads in more, but that hadn't been necessary before.


  • Moderator

    @Gamefanatic3D I can't find any mention of changes to G10, and the Z offset is in heavy use by people who use tool changers, so I'm not sure why it's not working for you. Is there anything in your tpre.g, tpost.g etc tool change commands (ie G10 Z0) that is overriding the settings in config.g?

    Also, see the note from https://duet3d.dozuki.com/Wiki/Gcode#Section_G10_Tool_Offset_and_Temperature_Setting:

    It's usually a bad idea to put a non-zero Z value in as well unless the tools are loaded and unloaded by some sort of tool changer or are on independent carriages. When all the tools are in the machine at once they should all be positioned at the same Z height to avoid a lower tool colliding with the object while a higher tool is printing.

    But I'm sure you knew that already!

    Ian



  • Yeah, this seems to be a constant battle of funky workings with each code update. I updated to this version to battle a problem I was having with the last upgrade. Each time something different. Maybe I just need to re-reflash.

    Only my tpost0.g has anything:

    M116 P0
    

    Getting things at the exact same Z-Height is a challenge and have always been able to utilize this feature to fix the issue.

    Since I'm tired of chasing the next fix, I'll probably just adjust this in the slicer onToolChange script for now, since that's essentially doing the same thing as using the BabyStepping.


  • administrators

    @Gamefanatic3D, please try upgrading RRF to 3.01-RC6. There have been lots of fixes since 3.0. You can keep your existing DWC version if it is 2.0.7 or 1.22.6.



  • So I upgraded the firmware and ran the tests again. Even adding 0.2 to the Z didn't make a change. I made the change while the printer was going just to make sure.

    Board: Duet WiFi 1.02 or later + DueX5
    Firmware: RepRapFirmware for Duet 2 WiFi/Ethernet 3.01-RC6 (2020-04-03b3)
    Duet WiFi Server Version: 1.23

    Went from:

    G10 P1 R0 S0 X17.6 Y-12.8 Z0.2
    

    To:

    G10 P1 R0 S0 X17.6 Y-12.8 Z0.4
    

    No change. Doing baby-stepping does change the height.



  • Okay, so I made some success on getting this to work this weekend, purely on accident. I was upgrading to the new web console and had an issue where the Bed was no longer being displayed in the tools of the web console after updating to Duet Web Control 2.1.7.
    I updated the firmware to 3.01-RC12 (2020-05-06b1), but still no change.

    Prior to finding the solution to my Bed heater problem, I removed config.json and any file "duet3" in the name. I don't know why, but this appears to have resolved the problem with my G10 offset not working. Now when I select the tools in the PanelDue the Z offset changes immediately as expected. I suspect these files were included from my original upgrade to v3.0 as they were included in the Duet2and3Firmware-3.0.zip.

    Ultimately I found the problem of my Bed not showing up being related to an additional "M140 H0" command being needed after defining it in the config.g.



  • Glad you've got it working.

    Just FYI I've been developing multi-tool alignment scripts for toolchangers. The ultimate output of such a script is a G10. I've had no problem with G10s working or not working on any 3.x beta or 3.x RCx. G10 tool offsets always work.

    My setup is a Duet 3 6HC + Pi (plus several expansion and tool boards, but they really aren't relevant to this; all XYZ motion is on the 6HC).

    Again, may or may not help you... just confirmation that there are no "bad" releases for this particular feature, based on my usage. YMMV



  • @Danal
    I'm not saying there is anything wrong with the release. Just noting what I had to go through to get things working. Its my belief that removing the additional firmware (which would be for your board) is what resolved my problem, though it could have just been the final upgrade to the v3 RC12.

    As a side note, I'm still not getting "filaments" to work. The config.g for those doesn't execute. Though they did before all my recent updates... 😢 have to rely on my slicer for most things still.


Log in to reply