Duet Wifi will not accept M672 S105:aaa:bbb command



  • Hi all,

    I've browsed this forum for a while an can almost always find a solution from a previous post. However, I have not been able to find a good answer for this one, so I'm hoping this post and the eventual answer will not only help myself but other users in the future. Thanks in advance for you time and all the great work!

    I have a Kossel Delta Printer running a Duet WiFi and using a smart effector with carbon rods. The thing runs great! However, my part cooling fan causes interference so the Z-probe always triggers.

    I found on the duet site that sending command M672 S105:aaa:bbb (with the appropriate values in place for those variables) will fix this issues. I've had success by setting aaa to 100 and bbb to 155. The issue is I am only able to send this command intermittently, and the printer will not save this sensitivity setting so i need to run it every time. Some days the command is accepted and everything is fine, other days I need to turn the fan off for any calibration or z-probed activities.

    I would really appreciate any help in understanding why the printer won't accept this command most of the time and how to fix that, and also how to make the printer store this sensitivity setting so I don't need to do this every time I turn it on.

    Thanks again in advance!

    Andy


  • Moderator

    @lawnica1 How old is your Smart Effector? There was a firmware update in November 2019 to fix this issue (see https://github.com/dc42/Duet3dSmartEffector/releases ). As for why the programming works sometimes and not others, I'd guess interference or wiring is the issue. Check your wiring and crimps to the Smart Effector. You can also add M672 it to your config.g so it runs at startup, so before any other motors or fans run.

    Ian



  • @droftarts Thanks for letting me know Ian! I got mine around September, so I might need to download that update. As far as the issue being intermittent, I don't think it's wiring because I can send other commands just fine. The M672 is the only command I've tried that didn't get accepted. I'm wondering if there is an order of operations that I am missing here, like home first than blah then run command?



  • @droftarts Oh also, I tried adding the command to my config.g in the probe section, but it didn't do anything either. How ever all other commands worked fine. I.e. home, delta auto-calibration, mesh bed leveling, etc. Of course i had to run those commands with the fan off so I wouldn't have interference.


Log in to reply