Z axis Homing issues



  • While the printer is on I run the homing for each of the axis each individually to make sure that they will home properly considering I just set up the duet 2 WiFi board on my Ender 3. When I home the z axis it will not move and just spit out an error code about motor 2 and then a g28 z error. After it spits out the motor 2 code and the g28 z error the web control shows that the z axis had moved and homed but it didn’t move at all. Is there anyway of resolving this?


  • administrators

    Can you post the error message?



  • Screen Shot 2020-04-14 at 2.13.40 PM.png

    On top of it giving me this in the error log the z stepper motor makes this horrible noise that sounds like something is grinding.



  • I'm also having the same issue that is presented with the z-axis on the y-axis. It is shooting out the same error message but for driver 1 in addition to the one that asked about.


  • Moderator

    The error message is telling you that your motor cable is probably not connected properly. Could be a bad crimp or maybe failing driver. Most likely a bad cable/crimp.



  • Thank you for the feedback I probably go through and check the crimps and might recrimp those 2 cables to make sure that they are properly connected. I also figured my sound issue which gives me the grinding noise. The z motor collar holding the lead screw for the z-axis is to close causing it to grind metal against metal.



  • I was able to get the y axis to work properly. But nothing I have tried to fix the z-axis has worked. If anybody wants to take a look at my configuration code to see if there is something I have to fix I am open to putting it up here otherwise I am going to try and see if there is something wrong with the configuration code that I had uploaded to the printer that might be causing the problems so I am going to try and flash the original configuration file to the printer to see if it will help with resolving my problems. Otherwise, I'm open to suggestions on what I can do to fix this issue.


  • Moderator

    Yes, please post your config.g

    Are you still getting the Phase B disconnected errors?



  • Yes I am still getting the Phase B disconnected error.

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Sun Apr 12 2020 18:32:22 GMT-0400 (Eastern Daylight Time)
    
    ; General preferences
    G90                                                ; send absolute coordinates...
    M83                                                ; ...but relative extruder moves
    M550 P"My Printer"                                 ; set printer name
    
    ; Network
    M552 S1                                            ; enable network
    M586 P0 S1                                         ; enable HTTP
    M586 P1 S0                                         ; disable FTP
    M586 P2 S0                                         ; disable Telnet
    
    ; Drives
    M569 P0 S0                                         ; physical drive 0 goes backwards
    M569 P1 S0                                         ; physical drive 1 goes backwards
    M569 P2 S1                                         ; physical drive 2 goes forwards
    M569 P3 S1                                         ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3                                   ; set drive mapping
    M350 X16 Y16 Z16 E16 I1                            ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E741.00                  ; set steps per mm
    M566 X600.00 Y600.00 Z60.00 E300.00                ; set maximum instantaneous speed changes (mm/min)
    M203 X9000.00 Y9000.00 Z600.00 E6000.00            ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z120.00 E5000.00              ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E900 I30                       ; set motor currents (mA) and motor idle factor in per cent
    M84 S30                                            ; Set idle timeout
    
    ; Axis Limits
    M208 X0 Y0 Z0 S1                                   ; set axis minima
    M208 X235 Y235 Z260 S0                             ; set axis maxima
    
    ; Endstops
    M574 X1 Y1 Z1 S1                                   ; set active high endstops
    
    ; Z-Probe
    M558 P0 H5 F120 T6000                              ; disable Z probe but set dive height, probe speed and travel speed
    M557 X10:220 Y10:220 S20                           ; define mesh grid
    
    ; Heaters
    M305 P0 T98801 B4185 R4700                         ; set thermistor + ADC parameters for heater 0
    M143 H0 S80                                        ; set temperature limit for heater 0 to 80C
    M305 P1 T98801 B4185 R4700                         ; set thermistor + ADC parameters for heater 1
    M143 H1 S255                                       ; set temperature limit for heater 1 to 255C
    
    ; Fans
    M106 P0 S0 I0 F20 H-1                              ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S0 I0 F20 H1 T45                           ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S0 I0 F20 H1:0 T45                         ; set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on
    
    ; Tools
    M563 P0 S"Hotend" D0 H1 F0                         ; define tool 0
    G10 P0 X0 Y0 Z0                                    ; set tool 0 axis offsets
    G10 P0 R0 S0                                       ; set initial tool 0 active and standby temperatures to 0C
    
    ; Custom settings are not defined
    
    ; Miscellaneous
    M501                                               ; load saved parameters from non-volatile memory
    M911 S21 R23 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; set voltage thresholds and actions to run on power loss
    T0                                                 ; select first tool
    
    

  • Moderator

    Have you checked your cables and crimps?



  • I haven't yet checked the crimps I will probably do that sometime tomorrow because of it being kinda late to check it. However, I will probably go over the crimp connectors and the cable to make sure that everything was properly done.


  • Moderator

    The error would strongly indicate that. Your config.g looks ok.



  • I found out that the z-axis had a bad crimp. I recrimped the all the wires that are used for the z-axis to make it so that it might work. I will probably get back then if it is working or not.


  • Moderator

    Hopefully that solves the problem for you. Let us know if you encounter any other issues.



  • Just checked through the individual homing for each of the axes and got them to run properly. Thank you for the help on my journey of getting the duet wifi board to work in an Ender 3. I will probably in the next week our 2 do a write up for you guys if you want it as a direct guide on what a person has to do to install a duet wifi board in an Ender 3 and what things the person has to look out for because it took me close to almost 2 and a half weeks to install and troubleshoot all the things related to install the board on my printer.


  • Moderator

    Sure if you'd like to do a write up that would be great.

    There is currently a 5 part guide on adapting an Ender 3 Pro and a Duet Maestro, which is a little different to the Duet wifi.

    https://duet3d.dozuki.com/Guide/Ender+3+Pro+and+Duet+Maestro+Guide+Part+1:+Wiring/37

    Not sure if you saw that yet or not. Some of the specifics won't match, but the commissioning and calibration steps are generally applicable.


Log in to reply