Printing dont starts at the center of the bed



  • Hi,

    i have an another issue, my printer dont start at the center of the bed, and i can't find the issue in my config.

    ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Sun Apr 12 2020 21:12:30 GMT+0200 (Mitteleuropäische Sommerzeit)
     
    ; General preferences
    G90                                      ; send absolute coordinates...
    M83                                      ; ...but relative extruder moves
    M550 P"BLV AM8"                          ; set printer name
     
    ; Network
    M552 S1                                  ; enable network
    M586 P0 S1                               ; enable HTTP
    M586 P1 S0                               ; disable FTP
    M586 P2 S0                               ; disable Telnet
     
    ; Drives
    M569 P0 S0                               ; physical drive 0 goes backwards
    M569 P1 S0                               ; physical drive 1 goes backwards
    M569 P2 S1                               ; physical drive 2 goes forwards
    M569 P3 S1                               ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3                         ; set drive mapping
    M350 X16 Y16 Z16 E16 I1                  ; configure microstepping with interpolation
    M92 X80.456 Y80.6956 Z408.1451 E385.00   ; set steps per mm
    M566 X600.00 Y600.00 Z18.00 E300.00      ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E6000.00  ; set maximum speeds (mm/min)
    M201 X1500.00 Y1500.00 Z100.00 E10000.00 ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E1000 I50            ; set motor currents (mA) and motor idle factor in per cent
    M84 S30                                  ; Set idle timeout
     
    ; Axis Limits
    M208 X-33 Y-10 Z0 S1                     ; set axis minima
    M208 X220 Y220 Z240 S0                   ; set axis maxima
     
    ; Endstops
    M574 X1 Y1 S0                            ; set active low and disabled endstops
    M574 Z1 S2                               ; set endstops controlled by probe
     
    ; Z-Probe
    M307 H3 A-1 C-1 D-1			             ; Disable the 3th Heater to free up PWM channel 5 on the Duex board.
    M558 P9 H3 F120 T6000 A10 S0.003 B1 R0.5 ; set Z probe type to bltouch and the dive height + speeds
    G31 P25 X30.44 Y-9.48 Z0.7              ; set Z probe trigger value, offset and trigger height
    M557 X5:200 Y5:200 S20                   ; define mesh grid
     
    ; Heaters
    M307 H0 B0 S1.00                         ; disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4725 C7.060000e-8 R4700 ; set thermistor + ADC parameters for heater 0
    M143 H0 S130                             ; set temperature limit for heater 0 to 130C
    M305 P1 T100000 B4725 C7.060000e-8 R4700 ; set thermistor + ADC parameters for heater 1
    M143 H1 S275                             ; set temperature limit for heater 1 to 275C
     
    ; Fans
    M106 P0 S0 I0 F500 H-1                   ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H-1                   ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 S1 I0 F500 H-1                   ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
     
    ; Tools
    M563 P0 D0 H1 F0                         ; define tool 0
    G10 P0 X0 Y0 Z0                          ; set tool 0 axis offsets
    G10 P0 R0 S0                             ; set initial tool 0 active and standby temperatures to 0C
     
    ; BLTouch startup
    G4 S2					                 ; Pause a couple seconds
    M280 P64 S160				             ; Clear any alarms
    G4 S2					                 ; Pause a couple seconds
    M402					                 ; retract pin just in case	
     
    M912 P0 S3.4
     
    ; Miscellaneous
    T0                                       ; select first tool
    

  • administrators

    This is usually a slicer setting and not a firmware problem. What slicer are you using?


  • administrators

    From your axis limits I assume that you have set them so that X0 Y0 is at one corner of the bed, and the other corner is X220 Y220. To print at the centre you need to tell your slicer what the bed dimensions are and/or tell it that the centre is at X110 Y110.

    Alternatively you can set the axis limits so that X0 Y0 is the beds centre, and configure that in your slicer too. See https://duet3d.dozuki.com/Wiki/Centering_the_bed_or_setting_the_bed_origin.



  • Thank you, im using Cura 4.4!
    This are my settings for my printer, and normaly it should be okay (i think)
    Cura Settings


  • Moderator

    When in the homed position is the nozzle off the edge of the bed? If so you can use a negative value for the M208 minima to indicate how far off the bed edge the nozzle is when homed. That will help keep the slicer and firmware bed centers synced up.



  • Thank you guys, i couldn't find any option under Cura to set the center at X110 Y110.
    I set the axis limits to M208 X-25 Y20 Z0 S1 and it seems to be centered now.



  • Sounds like you have it working... but... if you ever wish Cura to generate G-Code that assumes 0,0 is at the center of the bed:

    4d25a632-c8fe-44a8-8d41-03dba338b321-image.png

    Again, don't do this unless you also change the printer to match...


  • Moderator

    @TiToMoskito said in Printing dont starts at the center of the bed:

    M208 X-25 Y20 Z0 S1

    Y20 would mean that your nozzle won't be able to reach the front edge of the bed. Is that an actual physical limitation?


Log in to reply