Bed probing with BLTouch not working



  • I have seen the documentation and believe i have set all up correctly but the G29 cmd replies with an error:
    "Error G29: no valid grid defined for bed probing"
    the machine is a Makergear M2 With Duet2 WiFi

    Firmware Name: RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Electronics: Duet WiFi 1.0 or 1.01
    Firmware Version: 2.03 (2019-06-13b2)
    WiFi Server Version: 1.21
    Web Interface Version: 1.21

    config:
    ; Configuration file for Makergear M2 Duet (firmware version 2.03)
    ; General Preferences
    M111 S0 ; Debug off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 PMakergear M2 ; Machine name (can be anything you like)
    M551 ; Machine password (currently not used)

    ; Network
    ;*** If you have more than one Duet on your network, they must all have different MAC addresses, so change the last digits
    M540 P0xBE:0xEF:0xDE:0xAD:0xFE:0xED ; MAC Address (hexadecimal)

    ;*** Wifi Networking
    M552 S1 ; Enable WiFi
    M555 P2 ; Set output to look like Marlin
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet
    M575 P1 B57600 S1 ; Comms parameters for PanelDue

    ; Drives

    M569 P0 S0 ; X axis direction
    M569 P1 S0 ; Y axis direction
    M569 P2 S1 ; Z axis direction
    M569 P3 S1 ; Extruder Drive 0
    M584 X0 Y1 Z2 E3
    M350 X16 Y16 Z16 E16 I1 ; Set 16x microstepping with interpolation
    M92 X80.12 Y80.12 Z399.78 ; Set axis steps/mm
    M566 X800 Y980 Z12 E180 ; Minimum speeds mm/minute
    M203 X6000 Y6000 Z1500 E3000 ; Maximum speeds (mm/min)
    M201 X800 Y800 Z400 E10000 ; Accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30 ; Set motor currents (mA)
    M84 S30 ; Set idle timeout
    M564 H0

    ; Limits
    M208 X0 Y0 Z0 S1 ; set axis minimum (adjust to make X=0 the edge of the bed)
    M208 X205 Y255 Z205 ; set axis maxima (adjust to suit your machine)

    ; End Stops
    M574 X1 Y1 S0 ; set endstop configuration (X and Y endstop only, at low end, active high)
    M574 Z1 S2 ; Define Z to use probe. S2=Home to minimum

    ; Z-Probe Bltouch
    M307 H7 A-1 C-1 D-1 ; disable Heater7 to free up PWM channel 5 on Duex board for BLTouch
    M558 P9 H5 F500 R0.2 T6000 X0 Y0 Z1 ; P=Select Z-probe type/mode=9 for BLtouch. H=DiveHeight above bed(mm), F=Speed the bed moves, T=Travel Speed between points
    G31 P1000 X24 Y0 Z1.55 ; P=Z probe trigger value,X&Y=offset for mount relative to nozzle (mm), Z=trigger height "Z-offset"(mm)
    M577 X0:180 Y0:250 S10
    ; Heater and thermistor section
    ;*** If you have a Duet board with 1K thermistor series resistors, change R4700 to R1000 to the following M305 commands

    M307 H1 A350.1 C103.5 D4.0 B0
    M305 P0 T100000 B3950 R4700 H0 L0 ; Put your own H and/or L values here to set the bed thermistor ADC correction
    M305 P1 R4700 T100000 B3988 ; Put your own H and/or L values here to set the bed thermistor ADC correction
    M143 H0 S280

    ;Tool definition section

    M563 P0 D0 H1 ; Define tool 0 to use extruder drive 0 and heater 1
    G10 P0 S0 R0 ; Set tool 0 operating and standby temperatures
    ;Bed tramming

    ;*** if you are using axis compensation, put the figures in the following command
    M556 S78 X0 Y0 Z0 ; Axis compensation here
    T0 ; select first hot end

    Bed.g

    M561
    G28
    G29
    M577 X5:205 Y5:255 S30

    Not sure what to do next. I have looked at the documentation on the web site but i have to be missing something.



  • M577 X0:180 Y0:250 S10

    You have wrong command to define mesh grid, it should be M557, but you have M577.



  • I new it would be simple but was not seeing it. even after looking at my other 3d printer. Thanks so much. working fine now


Log in to reply