Auto tuning keeps failing



  • I have followed the instructions and every time the tuning fails for the bed and hotend heaters. I think I must be missing or not understanding something.

    Heater 0 is being tuned, phase 3 of 3
    Auto tune of heater 0 with P=0.50 S=70.0 cancelled because temperature limit exceeded. Use lower P or higher S in m303 command.

    Heater 1 is being tuned, phase 3 of 3
    Auto tune of heater 1 with P=0.47 S=240.0 cancelled because temperature limit exceeded. Use lower P or higher S in m303 command.

    It seems as if the temperature just keeps climbing until the S parameter is reached and then it fails

    This is my config file:-

    M555 P2 ; Set output to look like Marlin
    G21 ; Work in millimetres
    G90 ; Send absolute corrdinates…
    M83 ; ...but relative extruder moves
    M574 X0 Y2 Z0 S1 ; set endstop configuration (Y endstop only, at high end, active high)
    M92 X87.4890 Y87.4890 Z4000 ; Set axis steps/mm
    M906 X950 Y950 Z900 E850 ; Set motor currents (mA)
    M556 S79.5 X0.75 Y1.05 Z0.35 ; axis compensation
    M201 X500 Y500 Z15 E1000 ; set accelerations
    M203 X9000 Y9000 Z100 E3600 ; set maximum XYZ and extruder speeds
    M566 X300 Y300 Z30 E20 ; Maximum instantaneous speed changes mm/minute
    M208 X200 Y200 Z190 ; set axis maxima
    M208 X0 Y7 Z-1 S1 ; set axis minimum (adjust to make X=0 the edge of the bed)
    M305 P0 R1000 H40 L-26 X0 ; H and/or L values to set the bed thermistor ADC correction
    M305 P1 R1000 H40 L-26 X1 ; H and/or L values to set the 1st nozzle thermistor ADC correction
    M558 P1 ; Use an unmodulated Z probe or an intelligent Z probe
    G31 Z1.9 P500 ; Set the probe height and threshold

    ; ********** Single nozzle settings **********
    M563 P0 D0 H1 ; Define tool 0
    M92 E430 ; Set extruder steps per mm (single nozzle)

    ; ********** Diamond nozzle settings **********
    ;M563 P0 D0:1:2 H1 ; Define tool 0 extruder 0
    ;M563 P1 D0:1:2 H1 ; Define tool 1 extruder 1
    ;M563 P2 D0:1:2 H1 ; Define tool 2 extruder 2
    ;M567 P0 E1.0:0.0:0.0 ; single colour - extruder 0
    ;M567 P1 E0.0:1.0:0.0 ; single colour - extruder 1
    ;M567 P2 E0.0:0.0:1.0 ; single colour - extruder 2
    ;M92 E430:430:430 ; Set extruder steps/mm (multiple nozzles)
    ;M568 P0 S1 ; turn on mixing Tool 0
    ;M568 P1 S1 ; turn on mixing Tool 0
    ;M568 P2 S1 ; turn on mixing Tool 0



  • For my overpowered bed heater I had to use M303 P0.1 S140 then I had to add a B0 to the M307 to use PID mode.
    For the hotend with a 40w 24v cartridge, I used either P0.2 or P0.3 with a S250

    So, you just need to lower the P number, or raise the S number, or both.



  • I have now completed an auto tune of the hot end "M303 H1 P0.15 S210 "
    This is the result
    Heater 1 model: gain 568.0, time constant 185.4, dead time 14.0, max PWM 1.00, in use: yes, mode: PID
    Setpoint change: P4.2, I0.02, D40.8
    Load change: P4.2, I0.15, D40.8

    However, when the hot end reached the set temperature, I switched on my secondary cooling fan at 50% speed and the hot end temperature dropped dramatically and took a long time to recover.

    If this happened during a print, the consequences could be a failed print.

    This should be in the section tuning and not installation so please comment on the new thread.


  • administrators

    I didn't see a new thread, so I'll reply here.

    • Version 1.15b and earlier firmware were slow to respond if the temperature dropped more than 1C. Firmware 1.15c should respond much faster.

    • If the PID parameters generated by auto tuning don't work for you, define your own PID parameters using a M301 command in config.g. Put it after the M307 command so that it overrides the ones generated by M307.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.