Sensorless homing corexy not working since upgrade to RR3



  • So i last used my printer with RR 1.2 just updated and renewed the config and everything works apart from the sensorless homing no matter what i set the motor current to or the sensitivity it just plants into the x home and makes loads of noise i have included my complete config and also the testing macro that i am using.

    ; Configuration file for Duet WiFi (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Wed Apr 22 2020 22:44:08 GMT+0100 (British Summer Time)
    
    ; General preferences
    G90                                            ; send absolute coordinates...
    M83                                            ; ...but relative extruder moves
    M550 P"HEVO"                                   ; set printer name
    
    M669 K1                                        ; select CoreXY mode
    
    ; Network
    M552 S1                                        ; enable network
    M586 P0 S1                                     ; enable HTTP
    M586 P1 S0                                     ; disable FTP
    M586 P2 S0                                     ; disable Telnet
    M552 P192.168.1.103							   ; set fixed IP
    
    ; Drives
    M569 P0 S1                                     ; physical drive 0 goes forwards
    M569 P1 S1                                     ; physical drive 1 goes forwards
    M569 P2 S1                                     ; physical drive 2 goes forwards
    M569 P3 S0                                     ; physical drive 3 goes backwards
    M584 X0 Y1 Z2 E3                               ; set drive mapping
    M350 X16 Y16 Z16 E16 I1                        ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z4000.00 E420.00             ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00            ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00        ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00            ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30                   ; set motor currents (mA) and motor idle factor in per cent
    M84 S30                                        ; Set idle timeout
    
    ; Axis Limits
    M208 X0 Y0 Z0 S1                               ; set axis minima
    M208 X300 Y00 Z200 S0                         ; set axis maxima
    
    ; Endstops
    M574 X1 S3                                     ; configure sensorless endstop for low end on X
    M574 Y1 S1 P"ystop"                            ; configure active-high endstop for low end on Y via pin ystop
    M915 X S5 F1 R0							       ; sensorless homing parameters
     
    ; Z-Probe
    M950 S0 C"exp.heater3"                         ; create servo pin 0 for BLTouch
    M558 P9 C"^zprobe.in" H5 F100 T2000            ; set Z probe type to bltouch and the dive height + speeds
    G31 P25 X36 Y10 Z2.5                           ; set Z probe trigger value, offset and trigger height
    M557 X15:215 Y15:195 S20                       ; define mesh grid
    
    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0                          ; create bed heater output on bedheat and map it to sensor 0
    M143 H0 S120                                   ; set temperature limit for heater 0 to 120C
    M307 H0 B1 S1.00                               ; enable bang-bang mode for the bed heater and set PWM limit
    M140 H0                                        ; map heated bed to heater 0
    M308 S1 P"e0temp" Y"thermistor" T100000 B4138  ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1                           ; create nozzle heater output on e0heat and map it to sensor 1
    M143 H1 S280                                   ; set temperature limit for heater 1 to 280C
    M307 H1 B0 S1.00                               ; disable bang-bang mode for heater  and set PWM limit
    
    ; Fans
    M950 F0 C"fan0" Q500                           ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H-1                                 ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500                           ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H1 T45                              ; set fan 1 value. Thermostatic control is turned on
    
    ; Tools
    M563 P0 S"E3D V6" D0 H1 F0                     ; define tool 0
    G10 P0 X0 Y0 Z0                                ; set tool 0 axis offsets
    G10 P0 R0 S0                                   ; set initial tool 0 active and standby temperatures to 0C
    
    ; Custom settings are not defined
    
    
    
    M400                    ; make sure everything has stopped before we make changes
    M574 X1 S3              ; set endstops to use motor stall
    M913 X25        ; reduce motor current to 50% to prevent belts slipping
    G91                     ; use relative positioning
    G1 H1 X-300 F4000 ; move all carriages up 700mm, stopping at the endstops           
    G90                     ; back to absolute positioning
    M400                    ; make sure everything has stopped before we reset the motor currents
    M913 X100 Y100 Z100     ; motor currents back to normal
    G1 X0 Y0 F2000          ; centre the head and set a reasonable feed rate
    M574 X2 Y2 Z2 S1        ; set endstops back to normal so that homedelta.g works
    

    for some reason when i run the macro it moves the Y axis toward the back?

    yes i know it makes more sense to use a physical endstop but it worked when i built the printer and havent easily left space to wire in the additional stop


  • administrators

    @robbrown92 said in Sensorless homing corexy not working since upgrade to RR3:

    ; Endstops
    M574 X1 S3 ; configure sensorless endstop for low end on X
    M574 Y1 S1 P"ystop" ; configure active-high endstop for low end on Y via pin ystop
    M915 X S5 F1 R0 ; sensorless homing parameters

    On a CoreXY machine, to use stall detect homing on either X or Y, you must set the stall sensitivity on both the X and Y motors. S2 or S3 is usually about right.



  • I changed the code to

    M574 X1 S3                                     ; configure sensorless endstop for low end on X
    M574 Y1 S1 P"ystop"                            ; configure active-high endstop for low end on Y via pin ystop
    M915 X:Y S5 F1 R0							       ; sensorless homing parameters
    
    

    it still runs into the x end and they pushes the y axis back



  • scratch last i changed the sensitivity to S2 and it worked but it also jogged the Y axis back slightly is this a belt tension issue? ps thanks for your help and the speedy responses


Log in to reply