CURA slicer speed not matching print speed



  • On the DWC, The requested speed is 8 mm/s and top speed is 8 mm/s. This leads me to believe the duet is doing what it needs to. The model is where it should be on the build plate and everything is executing properly except for the speed. I have set the print speed to 50 mm/s but it's only doing 8 mm/s. Homing is also painfully slow when running a gcode file from CURA. It's quick and as expected when homing manually in the DWC. This is an Ender 3 with a Duet Maestro installed. I used the same profile as I used on the Ender 3 before the Duet upgrade. This is how the speeds look.

    2d8abf8c-16a2-43ac-ad31-ee562e6460d6-image.png

    Any ideas what could be causing this seriously slow print speed while printing from CURA?



  • My drives section in config.g looks like this:

    ; Drives
    M569 P0 S0 ; physical drive 0 goes backwards
    M569 P1 S0 ; physical drive 1 goes backwards
    M569 P2 S1 ; physical drive 2 goes forwards
    M569 P3 S0 ; physical drive 3 goes backwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E128 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E805.12 ; set steps per mm
    M566 X600.00 Y600.00 Z24.00 E300.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X9000.00 Y9000.00 Z600.00 E6000.00 ; set maximum speeds (mm/min)
    M201 X400.00 Y400.00 Z100.00 E5000.00 ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E900 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout


  • Moderator

    Your cura printer settings and start gcode section probably has some commands setting speeds for marlin printers. Check your start gcode and delete any such lines, and also choose reprap gcode flavor.


Log in to reply