SOLVED! E0 Heater not accessible - Please help



  • Can you look through the config? - I can not access my nozzle heater anymore.
    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B3950 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0 ; create bed heater output on bedheat and map it to sensor 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M307 H0 B0 S1.00 ; disable bang-bang mode for the bed heater and set PWM limit
    M140 H0 ; map heated bed to heater 0
    M308 S1 P"e0temp" Y"pt1000" R4700 ; configure sensor 1 as PT1000 on pin e0temp
    M950 H1 C"e0heat" T1 ; create nozzle heater output on e0heat and map it to sensor 1
    M143 H1 S300 ; set temperature limit for heater 1 to 300C
    M307 H1 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit

    89749656-6f91-4814-becf-75b7e6fa9539-image.png



  • Board: Duet WiFi 1.02 or later
    Firmware: RepRapFirmware for Duet 2 WiFi/Ethernet 3.0 (2020-01-03b3)
    Duet WiFi Server Version: 1.23



  • My Tool settings was wrong I had S1 where it should have been H1

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C


Log in to reply