Solved: M207 doesn't affect firmware retraction



  • I'm experimenting with firmware retraction - G10 and G11 in the gcode. When I print, it is retracting, but trying variations of:
    M207 S4.0 R0.0 F6000 T6000 Z2.0
    M207 S4.0 R0.0 F3000 T3000 Z2.0
    M207 S4.0 F3000 Z2.0
    doesn't affect the retraction speed at all. It IS retracting, but it's much slower than 3000mm/min, but I can't get it to speed up (or slow down). I'm sure it's something simple, but I'm at a loss.

    Versions:
    Firmware Version: 1.18.1 (2017-04-09)
    WiFi Server Version: 1.03 (ch fork)
    Web Interface Version: 1.15a


  • administrators

    What speed limit have you set for the extruder in your M201 command, and what acceleration have you set in M203?

    With short amounts of retraction, the move will be acceleration-limited unless you configure a very high acceleration.



  • Not at my machine right now, but prior to trying firmware retraction (with unchanged accel/speed/jerk settings) I was retracting at 6000mm/min (8000 also worked, 9000 failed).

    What's really weird is that when I first tried firmware retraction a month or two ago, I didn't have this problem. Are there any other settings that could cause this?



  • M566 X1000 Y1000 Z100 E500 ; Maximum instantaneous speed changes (mm/min) (jerk)
    M203 X18000 Y18000 Z1000 E9000 ; Maximum speeds (mm/min)
    M201 X3000 Y3000 Z500 E3000 ; Accelerations (mm/s^2)



  • Tried it this morning and firmware retraction is working just as expected. Yesterday must have just been a glitch (in my head, most likely).


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.