BL-Touch error since updating to 3.01 RC12



  • It says:

    G28 Z
    Error: Z probe already triggered at start of probing move
    

    The probe worked well right before the update, and is the only relevant thing I changed since then

    What happens when I press home Z:

    1-Bed lowers 5mm as expected
    2-Probe deploys as expected
    3-Probe stays deployed for a couple seconds, but the bed doesn't move up
    4-Probe retracts, displays error message above

    Here's my package:

    pi@duet3:~ $ apt show duetsoftwareframework
    Package: duetsoftwareframework
    Version: 2.2.0
    Priority: standard
    Section: electronics
    Maintainer: Duet3D Packaging Authority <pkg@duet3d.com>
    Installed-Size: unknown
    Depends: duetcontrolserver (= 2.2.0), duetsd (= 1.0.6), duettools (= 2.2.0), duetwebserver (= 2.2.0), duetwebcontrol (= 2.1.7), reprapfirmware (>= 2.2.0-1), reprapfirmware (<= 2.2.0-999)
    Homepage: https://pkg.duet3d.com
    Vcs-Git: https://github.com/chrishamm/DuetSoftwareFramework.git
    Download-Size: 1,706 B
    APT-Manual-Installed: yes
    APT-Sources: https://pkg.duet3d.com unstable/armv7 armhf Packages
    Description: Meta package for the full Duet software framework
    
    N: There are 28 additional records. Please use the '-a' switch to see them.
    

    And M115:

    M115
    FIRMWARE_NAME: RepRapFirmware for Duet 3 MB6HC FIRMWARE_VERSION: 3.01-RC12 ELECTRONICS: Duet 3 MB6HC v0.6 or 1.0 FIRMWARE_DATE: 2020-05-06b1
    

    -The probe is not started in error state and does the self check fine on powerup
    -It also responds fine to deploy/retract commands

    Any idea?

    Cheers!



  • Okay little update...

    I checked the wiring, un/replugged the pins and now the error message is gone, the bed now moves up on a retracted probe....

    But it doesn't detect the trigger! which got me a nice dent on my pei now, but nothing broke thanks to my physical emergency stop mounted on the front of the machine...

    The probe now doesn't trigger at all during move up; what can it be now?

    Thanks


  • administrators

    • What firmware version were you using before the update, when it worked?
    • What M558 line do you have in config.g? In particular, have you enabled the pullup resistor on zprobe.in ?


  • @dc42 Hi,

    -RRF 3.01-RC11, DWC 2.1.6 and DSF 2.1.3 was working

    -Here's my bltouch area of config.g:

    ; BLTouch
    M558 P9 C"io7.in" H5 R1 F120 T6000 A5 S0.02 B1	        	; Define the bltouch input on io7.in
    M950 S0 C"io7.out"									; Define the bltouch servo on io7.out
    G31 X Y25 Z2 P25 									; Set the offsets for the bltouch
    


  • @dc42 Apologizes, this was actually a double wiring failure.

    It appears that the connector was faulty not only on the board, but also on the extension

    No idea how this could happen, will certainly shrink wrap it now

    Thanks


  • administrators

    I'm glad it's sorted. I recommend you change your M558 line to this:

    M558 P9 C"^io7.in" H5 R1 F120 T6000 A5 S0.02 B1 ; Define the bltouch input on io7.in

    (not the ^ before io7.in) in case you ever replace the BLTouch by a more recent version.


Log in to reply