Duet3 and Pi issue



  • Hello, I ran into this weird issue that only the heater 0 is detected on DWC.
    de78bb1a-5f4c-4133-a457-63456875f027-image.png
    I am sure this should be a quick fix but I could not figure out how.
    Here is my Config.g

    ; Configuration file for Duet 3 (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Wed Apr 01 2020 22:14:44 GMT-0500 (Central Daylight Time)
    
    ; General preferences
    G90                                             ; send absolute coordinates...
    M83                                             ; ...but relative extruder moves
    ;M550 P"duet3"                            ; set printer name
    M575 P1 B57600 S1
    
    ; Network
    M552 P0.0.0.0 S1                                ; enable network and acquire dynamic address via DHCP
    M586 P0 S1                                      ; enable HTTP
    M586 P1 S0                                      ; disable FTP
    M586 P2 S0                                      ; disable Telnet
    
    ; Drives
    M569 P0.0 S1 D3                                  ; physical drive 0.0 goes forwards
    M569 P0.1 S1 D3                                   ; physical drive 0.0 goes forwards
    M569 P0.2 S0 D3                                   ; physical drive 0.2 goes forwards
    M569 P0.3 S1 D3                                   ; physical drive 0.3 goes forwards
    M569 P0.4 S0 D3                                   ; physical drive 0.4 goes forwards
    M569 P0.5 S0 D3                                   ; physical drive 0.5 goes forwards
    M584 X0.0 U0.1 Y0.2 Z0.3 E0.4:0.5                    ; set drive mapping
    M350 X16 U16 Y16 Z16 E16:16 I1                      ; configure microstepping with interpolation
    M92 X200.00 U200.00 Y80.00 Z400.00 E420.00:420.00      ; set steps per mm
    M566 X900.00 U900.00 Y900.00 Z12.00 E120.00:120.00      ; set maximum instantaneous speed changes (mm/min)
    M203 X9000.00 U9000.00 Y6000.00 Z1500.00 E1200.00:1200.00 ; set maximum speeds (mm/min)
    M201 X1500.00 U1500.00 Y1500.00 Z1000.00 E250.00:250.00      ; set accelerations (mm/s^2)
    M906 X600 U600 Y1300 Z600 E600:600 I30                ; set motor currents (mA) and motor idle factor in per cent
    M84 S30                                         ; Set idle timeout
    
    ; Axis Limits
    M208 X-30 U26 Y0 Z0 S1                                ; set axis minima
    M208 X260 U316 Y190 Z186.7 S0                          ; set axis maxima
    
    ; Endstops
    M574 X1 P"io1.in" S1                                      ; configure sensorless endstop for low end on X
    M574 U2 P"io2.in" S1
    M574 Y2 P"!io5.in" S1                                      ; configure sensorless endstop for low end on Y
    M574 Z2 P"io6.in" S1                                      ; configure sensorless endstop for low end on Z
    M915 P0:1 S10 R1
    M915 P2 S10 R1
    
    ; Z-Probe
    M558 P1 I0 C"!io3.in" A5 R0.4 H6 F1300 T6000                 ; set Z probe type to switch and the dive height + speeds
    G31 P220 X0 Y0 Z0                            ; set Z probe trigger value, offset and trigger height
    ;G31 P{sensors.probes[0].value[0] + 30}
    ;G31 X0 Y0 Z0
    M557 X70:220 Y30:180 S75                        ; define mesh grid
    
    
    ; Heaters
    M570 S99999
    M308 S0 P"temp0" Y"thermistor" T100000 B4138    ; configure sensor 0 as thermistor on pin temp0
    M950 H0 C"out0" T0                              ; create bed heater output on out0 and map it to sensor 0
    M143 H0 S80                                    ; set temperature limit for heater 0 to 120C
    M307 H0 B0 S0.8                               ; enable bang-bang mode for the bed heater and set PWM limit
    M307 H0 A84.5 C473.8 D1.4
    M140 H0                                         ; map heated bed to heater 0
    M308 S1 P"temp1" Y"thermistor" T100000 B4138    ; configure sensor 1 as thermistor on pin temp1
    M950 H1 C"out1" T1                              ; create nozzle heater output on out1 and map it to sensor 1
    M143 H1 S240                                    ; set temperature limit for heater 1 to 240C
    M307 H1 B0 S1.00                                ; disable bang-bang mode for heater  and set PWM limit
    M307 H1 A593.7 C179.8 D9.3 V24.0
    M308 S2 P"temp2" Y"thermistor" T100000 B4138    ; configure sensor 2 as thermistor on pin temp2
    M950 H2 C"out2" T2                              ; create nozzle heater output on out2 and map it to sensor 2
    M143 H2 S240                                    ; set temperature limit for heater 2 to 240C
    M307 H2 B0 S1.00                                ; disable bang-bang mode for heater  and set PWM limit
    M307 H2 A532.1 C165.0 D10.3 V24.0
    M572 D0:1 S0.1:0.1								;Pressure Advance
    
    ; Fans
    M950 F0 C"out7" Q500                            ; create fan 0 on pin out4 and set its frequency
    M106 P0 L1.0 S0 H1 T60 S1.00                               ; set fan 0 value. Thermostatic control is turned on
    M950 F1 C"out8" Q500                            ; create fan 1 on pin out5 and set its frequency
    M106 P1 S0 H-1                                  ; set fan 1 value. Thermostatic control is turned off
    M950 F2 C"out4" Q500                            ; create fan 2 on pin out7 and set its frequency
    M106 P2 L1.0 S0 H2 T60 S1.0                               ; set fan 2 value. Thermostatic control is turned on
    M950 F3 C"out9" Q500                            ; create fan 3 on pin out6 and set its frequency
    M106 P3 S0 H-1                                  ; set fan 3 value. Thermostatic control is turned off
    
    ; Tools
    M563 P0 D0 H1 F0:1                              ; define tool 0
    G10 P0 X0 Y0 Z0                                 ; set tool 0 axis offsets
    G10 P0 R0 S0                                    ; set initial tool 0 active and standby temperatures to 0C
    M563 P1 D1 H2 X3 F0:3                              ; define tool 1
    G10 P1 U-0.0 Y1.0 Z-0.2                                 ; set tool 1 axis offsets
    G10 P1 R0 S0                                    ; set initial tool 1 active and standby temperatures to 0C
    
    ; Custom settings are not defined
    T0
    
    


  • None of your tools are showing in DWC, the M563 commands.

    I'm not 100% sure, but I think that is because of the F definitions. I believe they should match back to the P on the fans M106. Anyway, rather than attempt to verbalize all the "connect the dots", Here is what works for me:

    ; Temperature sensors
    M308 S0 P"0.temp0" Y"thermistor" T100000 B3950 A"Bed" 
    M308 S1 P"1.temp0" Y"thermistor" T100000 B3950 A"HE1"
    M308 S2 P"1.temp1" Y"thermistor" T100000 B3950 A"HE2"
    M308 S3 P"22.temp0" Y"thermistor" T100000 B3950 A"HE3"
    ;M308 S4 P"23.temp0" Y"thermistor" T100000 B3950 A"HE4"
    
    ; Heaters
    M950 H0 C"0.out0" T0           ; Bed.  H = Heater 0, C is output for heater itself, T = Temperature sensor (defined above)
    M950 H1 C"1.out0" T1           ; Heater for extruder out tool 0
    M950 H2 C"1.out1" T2           ; Heater for extruder out tool 1
    M950 H3 C"22.out0" T3           ; Heater for extruder out tool 2
    ;M950 H4 C"23.out0" T4           ; Heater for extruder out tool 3
    
    ; Further setup for bed
    M143 H0 S130                                           ; set temperature limit for heater 0 to 130C
    M307 H0 B0 S1.00                                       ; disable bang-bang mode for the bed heater and set PWM limit
    M140 H0                                                ; map heated bed to heater 0
    
    ; Default heater model
    ;;;;M307 H0 A270.7 C90.4 D6.7 B0 S1.0          ; Default Bed Heater Parameters, before tuning / if config-override.g is missing
    ; Calibration 28 Oct 2019
    ;Heater 0 model: gain 139.6, time constant 252.2, dead time 0.7, max PWM 1.00, calibration voltage 24.5, mode PID
    ;Computed PID parameters for setpoint change: P468.8, I35.594,  D225.7
    ;Computed PID parameters for     load change: P468.8, I136.631, D225.7
    M307 H0 A140 C252 D0.7 S1.0 V24.5 B0       ; Tuned Bed Heater Paramaters, same as report above, also B0 to turn off bang-bang
    
    ; Fans for hot end cooling
    M950 F1 C"1.out6"
    M106 P1 S255 H1 T45    ; S = Speed of fan Px, Hxx = heater for thermo mode, T = temps for thermo mode.
    M950 F2 C"1.out7"
    M106 P2 S255 H2 T45    ; S = Speed of fan Px, Hxx = heater for thermo mode, T = temps for thermo mode.
    M950 F3 C"22.out1"
    M106 P3 S255 H3 T45    ; S = Speed of fan Px, Hxx = heater for thermo mode, T = temps for thermo mode.
    ;M950 F4 C"23.out1"
    ;M106 P4 S255 H4 T45    ; S = Speed of fan Px, Hxx = heater for thermo mode, T = temps for thermo mode.
    
    ; Fans for print cooling
    M950 F5 C"1.out3" 
    M106 P5 C"PrintCool5"
    M950 F6 C"1.out4" 
    M106 P6 C"PrintCool6"
    M950 F7 C"22.out2" 
    M106 P7 C"PrintCool7"
    ;M950 F8 C"23.out2" 
    ;M106 P8 C"PrintCool8"
    
    ; Tool definitions
    M563 P0 S"Tool 0" D0 H1 F5      ; Px = Tool number, Dx = Drive Number (start at 0, after movement drives), H1 = Heater Number, Fx = Fan number print cooling fan
    G10  P0 S0 R0                   ; Set tool 0 operating and standby temperatures(-273 = "off")
    ;M572 D0 S0.1  		            ; Set pressure advance on 
    
    M563 P1 S"Tool 1" D1 H2 F6      ; Px = Tool number, Dx = Drive Number (start at 0, after movement drives), H1 = Heater Number, Fx = Fan number print cooling fan
    G10  P1 S0 R0                   ; Set tool 0 operating and standby temperatures(-273 = "off")
    ;M572 D1 S0.1		            ; Set pressure advance on 
    
    M563 P2 S"Tool 2" D2 H3 F7      ; Px = Tool number, Dx = Drive Number (start at 0, after movement drives), H1 = Heater Number, Fx = Fan number print cooling fan
    G10  P2 S0 R0                   ; Set tool 0 operating and standby temperatures(-273 = "off")
    ;M572 D2 S0.1		            ; Set pressure advance on
    
    


  • Thank you, it seems like I put 2 S parameters in M106 which caused the issue.


  • administrators

    @Ray11 said in Duet3 and Pi issue:

    Thank you, it seems like I put 2 S parameters in M106 which caused the issue.

    Odd, normally it just ignores the second one if you provide duplicate parameters.


Log in to reply