Error: M350: Driver 20 does not support x8 microstepping



  • I have been going nuts trying to get my quad Z motors configured right. I thought I had everything figured out but now I am getting the error:
    Error: M350: Driver 20 does not support x8 microstepping

    The extruder was moved to my toolboard at 20.0 and I did not specify interpolation but it gives me the error as if I did.

    See my config below. Can someone tell me what I need to change?

    ; Configuration file for Duet 3 (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Tue Apr 28 2020 11:01:38 GMT-0400 (Eastern Daylight Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"BAP" ; set printer name

    ; Drives
    M569 P0.0 S1 ; physical drive 0.0 goes forwards
    M569 P0.1 S0 ; physical drive 0.1 goes backwards
    M569 P0.2 S0 ; physical drive 0.2 goes backwards
    M569 P0.3 S0 ; physical drive 0.3 goes backwards
    M569 P0.4 S0 ; physical drive 0.4 goes backwards
    M569 P0.5 S1 ; physical drive 0.5 goes forwards
    M569 P20.0 S0 ; physical tool board drive 20.0 goes backwards

    ; Motor remapping for quad Z
    M584 X0.0 Y0.1 Z0.2:0.3:0.4:0.5 E0.20 ; set drive mapping
    M671 X-125:825:745:-125 Y0:0:835:835 S10 F1 ;lead screws clockwise front right z1, front left z2, rear left z3, rear right z4
    M350 X16 Y16 Z16 I1 ; Configure microstepping with interpolation
    M350 E8 ; Set Extruder to 8x Microstepping with no interpolation
    M92 X64 Y64 Z400 E409 ; Set steps per mm
    M566 X500.00 Y500.00 Z24.00 E24.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X10000 Y10000 Z600 E3600 ; Set maximum speeds (mm/min)
    M201 X3000 Y3000 Z250 E120 ; Set accelerations (mm/s^2)
    M906 X1000 Y1000 Z1000 E1000 I75 ; Set motor currents (mA) and motor idle factor in %
    M84 S3000 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X760 Y690 Z800 S0 ; set axis maxima

    ; Endstops
    M574 X1 S1 P"io1.in" ; configure active-high endstop for low end on X via pin io1.in
    M574 Y1 S1 P"io2.in" ; configure active-high endstop for low end on Y via pin io2.in
    M574 Z1 S2 ; configure Z-probe endstop for low end on Z

    ;M574 Z1 S1 P"io3.in" ; old z min configure active-high endstop for low end on Z via pin io3.in

    ; Z-Probe
    M950 S0 C"20.io0.out" ; create servo pin 0 for BLTouch
    M558 P9 C"20.io0.in" H10 F120 T13000 ; set Z probe type to bltouch and the dive height + speeds
    G31 P25 X-15 Y-40 Z2.5 ; set Z probe trigger value, offset and trigger height
    M557 X30:765 Y50:700 S200

    ; Heaters
    ; old M308 S1 P"20.temp0" Y"thermistor" T100000 B4725
    M308 S1 P"20.temp0" Y"thermistor" R2200 T100000 B4725 C7.06e-8 ; configure sensor 1 as thermistor on pin 20.temp0
    M950 H0 C"20.out0" T1 ; create nozzle heater output on 20.out0 and map it to sensor 0
    M143 H0 S300 ; set temperature limit for heater 0 to 280C
    M307 H0 A400 C250.0 D18 B0 V13.4

    ; Fans
    M950 F0 C"20.out2" ; Tool board hot end fan
    M106 P0 C"Hot End fan" S1 H1 T45 ; set fan 0 name and value. Thermostatic control is turned on
    M950 F1 C"20.out1" ; Tool board print cooling fan, no tacho
    M106 P1 C"Part Cooler" S0 ; set fan 1 value. Thermostatic control is turned off

    ; Tools
    M563 P0 D0 F0 H0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings

    ; Miscellaneous
    M501 ; load saved parameters from non-volatile memory
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; set voltage thresholds and actions to run on power loss


  • administrators

    Which firmware versions are you using, both on the main board and the tool board? Current is 3.01-RC12 on main board and 3.01-RC11 on tool board.



  • @dc42 rc11 on main and tool board



  • @jdumoulin
    The extruder will not move even if I take interpolation out for the other drives.



  • @jdumoulin said in Error: M350: Driver 20 does not support x8 microstepping:

    E0.20

    Scratch all that. I finally found the typo. Im sorry to have wasted your time on this. I checked this thing over and over.
    Extruder was listed as E0.20 instead of E20.0


Log in to reply