[solved] Several Newbie questions - porting fron RRF2 to RRF3



  • Hi all,
    Hope some good soul can give me some advice . Finally I'm here on the RRF3 too. The 2.05.1 produce some strange errors. If I try to use the micro-steps suddenly the heater report fault. The height come wrong and the printer restart to print too hight or too low. Anyway lets go on..
    I have installed the RRF 3.01.rc12 . Paneldue 7i updated at 1.24. Web control to 2.1.7. DuetWIFI rev 1.02
    Delta printer as 3D printer.
    I tried to dig in guides and https://www.reprap.org/wiki/G-code but I still miss to many stuffs.
    https://duet3d.dozuki.com/Wiki/RepRapFirmware_3_overview#Section_Summary_of_what_you_need_to_do_to_convert_your_configuration_and_other_files

    1)EDIT: Where I can found the real PIN names of the board?(schema or list). I thought they could be the names of the board diagram but they are not.Ex: for bed thermistor I expected "thermistor0" instead seems to be "bedtemp". So for sure I copy-pasted wrong names everywhere.
    Ok I was blind/fuse, found the list...hemm...I'll try to read better.

    2a)EDIT: The PanelDue 7i didn't show any temp despite the webcontrol does (also if wrong values) . No nozzle heater , no bed heater , no chamber heater , no extra heater added.
    Reading is a good practice: https://github.com/dc42/RepRapFirmware/blob/v3-dev/WHATS_NEW_RRF3.md
    Added to the M575 P1 S1 B57600 to config.g and the IAP.bin make the PaneDue work properly., Before was stuck on "connecting".

    2b) EDIT: I added a 4rth thermistor (as shown in the config.g) . How I can map it for RRF3?
    Reading the correct PIN name and M308 and M950 functions make me to insert the right value.

    2c) EDIT:The thermistors , except for the bed that is right, reports wrong values also if old setting are used. 100degree instead near 25.
    Basically the wrong setting leave report wrong values.
    Now this code work good for the heaters all.

    ; HEATERS :
    M308 S0 P"bed_temp" Y"thermistor" A"Bed" T100000 B3950 ; define bed temperature sensor 
    M950 H0 C"bed_heat" T0 ; heater 0 uses the bed_heat pin, sensor 0
    M308 S1 P"e0_temp" Y"thermistor" A"Nozzle" T100000 B4725 C7.06e-8 R4700; define E0 temperature sensor for nozzle
    M950 H1 C"e0_heat" T1 ; heater 1 uses the e0_heat pin and sensor 1
    M308 S2 P"e1_temp" Y"thermistor" A"H_C_Resistor" T100000  B4725 C7.06e-8 R4700  ; configure sensor 2 as thermistor on pin e1_temp for hot chamber 
    M950 H2 C"e1_heat" T2 ; heater 2 uses the e1_heat pin and sensor 2resistence
    M308 S3 P"e2temp" Y"thermistor" A"Enclosure" T10000    ; configure sensor 3 as thermistor on pin exp.35 for enclosure
    ;M950 P3 P"exp.heater3" T3; sensor 3 uses the exp.35 pin and sensor 3
    M140 H0 ; the bed heater is heater 0
    M141 H2 ; heater 2 is the chamber heater
    
    

    3)EDIT: Fans I would reach: FAN0 (connection on the schema) is for the nozzle in thermostatic mode. FAN1(connection on the schema) is for cooling the printed part and should be used by the slicer or manually controlled. FAN2 (connection on the schema) I would leave it manually for the hot chamber with a minimum of 30% on.
    As for before with the proper PIN names all came to work.

    4)EDIT: Endstop? If I try to home nothing move.
    They work fine:

    ; Endstops
    M574 X2 S1 P"xstop" ; Set active high endstops
    M574 Y2 S1 P"ystop"
    M574 Z2 S1 P"zstop"
    

    5)EDIT: Smart effector? I copy pasted , but of course I don't know if is right.
    It seems to work.

    6)EDIT: Filament sensor? Still as above how to map it?
    No error report but still to be tested

    ; Filament Sensor - Add the following to config file anywhere before the M501 command
    M591 D0 P1 C"e0_stop" R20 S1; configure extruder drive 0 to use E1 endstop (C4) with 20% tolerance , new extruder settings for filament sensor
    

    7)EDIT: The TOOL section have the fan reverted (nozzle - cooling part) but now I don know if this is still necessary because the new mapping system. In the case how to do that again?
    The exchange between the nozzle fan and tool fan is still valid.

    THANKS TO ANYONE WILL CONTRIBUTE 😀

    My config.g:

    Config.g
    
    ; General preferences
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    
    M575 P1 S1 B57600; enable panel due to connect properly
    
    M665 L400.320:400.310:400.310 R164.588 H508.538 B165.0 X-0.087 Y-0.059 Z0.000; Set diagonal rod length, delta radius,  printable radius and homed -
    M666 X0.00 Y0.0 Z0.0 A0.00 B0.00; Put your endstop adjustments here, or let auto calibration find them ; old setting M666 X0.45 Y0.40 Z-0.25  A0.00 B0.00;
    
    ; Network
    M550 PTEVO Little Monster ; Set machine name
    M552 S1
    G4 P1000
    M587 S"Vodafone-casa24" P"xxxxxxxxx"
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet
    
    
    ; Motors 0.9 degree
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X160 Y160 Z160 E920 ; Set steps per mm
    M566 X1200 Y1200 Z1200 E1200 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000 Y18000 Z18000 E1200 ; Set maximum speeds (mm/min)
    M201 X1000 Y1000 Z1000 E1000 ; Set accelerations (mm/s^2)
    M906 X1700 Y1700 Z1700 E1700 I60 ; Set motor currents (mA) and motor idle factor in per cent.I100 is idle 100% power motor. By def 1700 for axis and 1500 for Extruder for standard motors. For 0.9 motors use 1700 for 3 axis and 1700 for extruder (the motors are the same).
    ;M84 S30 ; Set idle timeout
    
    ; Axis Limits
    M208 Z0 S1 ; Set minimum Z
    
    ; Endstops
    M574 X2 S1 P"xstop" ; Set active high endstops
    M574 Y2 S1 P"ystop"
    M574 Z2 S1 P"zstop"
    
    ; Z-Probe
    M307 H3 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M558 P8 C"^zprobe.in+zprobe.mod" H5 F1200 T6000 A5 R0.4 ; P9 for BLTouch, dive height 5mm=H5 (can be less if the error margin is less than 0.2 , ex H3), probe at 100mm/min, travel 6000mm/min, up to 5 probes, pause 0.1s  ; M558 P8 R0.4 F1200 for smart effector
    G31 P100 X0 Y0 Z-0.05 ; Set Z probe trigger value, offset and trigger height. The higher the Z value, the closer the bed will get to the nozzle. G31 X0 Y20 Z1.150 P25  for BLT. - G31 P100 X0 Y0 Z-0.1 for SMART.
    M557 R165 S15 ; Define mesh grid
    
    
    
    
    ; HEATERS :
    
    M308 S0 P"bed_temp" Y"thermistor" A"Bed" T100000 B3950 ; define bed temperature sensor 
    M950 H0 C"bed_heat" T0 ; heater 0 uses the bed_heat pin, sensor 0
    M308 S1 P"e0_temp" Y"thermistor" A"Nozzle" T100000 B4725 C7.06e-8 R4700; define E0 temperature sensor for nozzle
    M950 H1 C"e0_heat" T1 ; heater 1 uses the e0_heat pin and sensor 1
    M308 S2 P"e1_temp" Y"thermistor" A"H_C_Resistor" T100000  B4725 C7.06e-8 R4700  ; configure sensor 2 as thermistor on pin e1_temp for hot chamber 
    M950 H2 C"e1_heat" T2 ; heater 2 uses the e1_heat pin and sensor 2resistence
    M308 S3 P"e2temp" Y"thermistor" A"Enclosure" T10000    ; configure sensor 3 as thermistor on pin exp.35 for enclosure
    ;M950 P3 P"exp.heater3" T3; sensor 3 uses the exp.35 pin and sensor 3
    M140 H0 ; the bed heater is heater 0
    M141 H2 ; heater 2 is the chamber heater
    M141 H2 ; heater 2 is the chamber heater
    
    
    ; Tools
    M563 P0 D0 H1 F1 S"Nozzle"; Define tool 0 L'F1 inverte la ventola del tool e le ventole di raffreddamento. cosi' quando sposto il cursore del tool varia correttamente l'intensita' della ventola del nozzle. (prima invece cambiavano le ventole di raffreddamento)
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    
    ; Fans
    M950  F0 C"fan0" T0
    M106 P0 S1  X1 H1 T45 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off - 0.3 is 30%
    M950  F1 C"fan1" T1
    M106 P1 S0 H-1 ; M106 P1 S0 I0 F500 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M950  F2 C"fan2" T2
    M106 P2 S0  H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off - 0.3 is 30%
    
    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss
    
    ; Custom settings
    ;M591 D0 C3 P2 E6.0 ;old extruder settings
    
    ; Filament Sensor - Add the following to config file anywhere before the M501 command
    M591 D0 P1 C"e0_stop" R20 S1; configure extruder drive 0 to use E1 endstop (C4) with 20% tolerance , new extruder settings for filament sensor
    
    ; Miscellaneous
    M501 ; Load saved parameters from non-volatile memory
    
    ; deployprobe.g
    ; called to deploy a physical Z probe
    
    ; generated by RepRapFirmware Configuration Tool on Sat Jul 07 2018 15:37:48 GMT-0700 (Pacific Daylight Time)
    
    M280 P3 S10 I1
    
    M280 P3 S90 I1
    
    


  • To read deeply and with more attention unveil lots of good stuffs. 😳


Log in to reply