Rough Running external Stepper Nema 34 from Drive 10 CONN_LCD



  • New to forum and not sure what else to do about getting my Nema 34 and CL86T to run smoothly. My setup consist of (2) Nema 23 X-axis, (1) Nema 23 Y-axis, (2) Nema 23 Z-axis, (1) Nema 23 Extruder E0, (1) Nema 34 E10, Duet 2 Wifi + Duex5, Meanwell 24V and 48V 504 Watt Power Supplies (both supplies reading steady 24 and 48 volts during testing). I am experiencing a rough vibration from the motor as it spins up to speed during a print but running a simple motor check gets the motor to spin up nicely without any roughness but with a slight hesitation before taking off. I am providing my Config File below. Thanks ahead for any help.
    https://youtu.be/FH7kXb8Q35g
    https://youtu.be/1MB7BXF49Wk
    Table Assembly2 Edit 134.1.jpg


  • administrators

    External drivers almost always need the M569 T parameter for that driver number to be set so as to meet the manufacturer's specifications for step pulse width and interval, and direction-to-step setup and hold times. Have you done that?



  • Yes I did that and I will add it again in config description below but motor still sounds rough and vibrates:

    ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Tue Apr 28 2020 19:28:52 GMT-0400 (Eastern Daylight Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"BILLy 2 Extruders Config File" ; set printer name

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S0 ; physical drive 2 goes backwards
    M569 P3 S0 ; physical drive 3 goes backwards
    M569 P10 S0 T2.5:2.5:5:0 ; physical drive 10 goes backwards
    M584 X0 Y1 Z2 E3:10 ; set drive mapping
    M350 X16 Y16 Z16 E16:16 I1 ; configure microstepping with interpolation
    M92 X320.00 Y320.00 Z320.00 E320.00:320.00 ; set steps per mm
    M566 X900.00 Y900.00 Z900.00 E200.00:200.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X3000.00 Y3000.00 Z3000.00 E1000.00:1000.00 ; set maximum speeds (mm/min)
    M201 X25.00 Y25.00 Z25.00 E10.00:10.00 ; set accelerations (mm/s^2)
    M906 X2000 Y2000 Z2000 E2000:2000 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X930 Y155 Z345 S0 ; set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 S1 ; set active high endstops

    ; Z-Probe

    ; Heaters
    M140 H-1 ; disable heated bed

    ; Fans

    ; Tools
    M563 P0 S"Print Head" D0:1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C
    M567 P0 E0.50:0.50 ; set mixing ratios for tool 0
    M563 P1 S"Conc Stuffer" D0:1 F0 ; define tool 1
    G10 P1 X0 Y0 Z0 ; set tool 1 axis offsets
    G10 P1 R0 S0 ; set initial tool 1 active and standby temperatures to 0C
    M567 P1 E0.50:0.50 ; set mixing ratios for tool 1

    ; Custom settings
    Mixing of Extruders RRF Config File Edited 4-28-20

    ; Miscellaneous
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; set voltage thresholds and actions to run on power loss

    T0 ; select first tool
    T10 ; select first tool
    20200513_114704[1].jpg


Log in to reply