Connecting . . .



  • I recently updated my Duet wifi to firmware 3.1 and was using it last night no problem. I also updated Duet Web Control to version 3.1. And this was working last night. Came in this morning and turned the machine and it just says "Connecting . . . " forever, without actually connecting. I have looked at threads about this connecting hangup but they reference older versions of firmware so I'm a little lost. I can connect via USB/YAT just fine. Tried a few things with YAT, even got YAT to say it was connected, but when I try and access via browser it never loads, just a blank screen.

    Any help would be greatly appreciated, feeling noob-y having these hanging issues two days in a row.


  • Moderator

    Connecting is on... the PanelDue?

    Do you have M575 P1 B57600 S1 in your config.g?



  • Ok, so I have to admit something really dumb. There had been a power surge or something and my wifi router had been knocked offline. I had not noticed this because I was working on a desktop computer with an ethernet connection that was unaffected. I rebooted the router and now I can see DWC in the browser and I can print, etc.

    All is more or less normal . . . except . . . on the PanelDue it does still read "connecting" in the upper right hand corner.
    The console in DWC shows that I have successfully connected, the console in the PanelDue does not show this.

    @Phaedrux I do not have "M575 P1 B57600 S1" in my config, should I?

    Apologies for really tripping over my own feet over here. Thanks again.



  • OK, so I added "M575 P1 B57600 S1" as @Phaedrux suggested, and everything is working great now, problem appears to be fully solved. I'll stop wasting your time now (I hope). Many thanks, this forum is remarkable.


  • Moderator

    @tom_lauerman it was a recent change for the panel due port on the duet 3 to make it a general purpose port rather than pre defined as a paneldue port. Seeing as it was the only predefined port. Now to enable the panel due the baud rate must be defined.


Log in to reply