Selecting a fixed IP address



  • My router does not appear to support NETBIOS; at least, even though I have set my printer name to 'coral' in the Duet WiFi setup, I can't access it as http://coral/ ; I have to use the IP address. Unfortunately the IP address is allocated through DHCP, so I have to look up the address on my router before I can connect to the Duet WiFi. Is there any way to specify a static IP address? My router reserves 192.168.0.2-10 for static IPs.

    Of course it would also be nice to get the address-by-name working, but I have the same problem with OpenELEC, OctoPi, and my Linux laptops not being findable by name either on the same network, so whatever's wrong there it probably has nothing to do with the Duet WiFi. The router does know the names and show them in the DHCP list.



  • I guess it depends on you router. On my BT HomeHub, if I click on a device in the DHCP list it comes up with a lot of info and some switches that can be set. One of them is "Always use the same IP address" which effectively makes it static although it has been assigned from the general DHCP pool. There might be something similar on your router.
    HTH



  • Sadly my router does not provide that option. But for my other devices, I have set the devices up to request specific IP addresses from the router, and that works rather well; the router recognizes that they have static IP addresses.


  • administrators

    The Duet WiFi is not yet support NetBIOS, but if does support mdns. See the installation instructions for how to use it.

    Most routers will allocate the same IP address to a device every time it appears.

    Supporting static IP addresses is on the firmware wish list.



  • Aha, thanks, it seems I needed to use http://coral.local/ . I take it that this is the name I entered in the WiFi setup, and not the name I entered in the config.g setup file? (I entered the same name, naturally enough, but if I want to change it I guess I'll have to go through the rigmarole with using the Duet WiFi as an AP again?)


  • administrators

    If the name you entered during WiFi setup is coral, then coral.local is how you address it via mdns. The name defined in config.g is not currently used for network accessing.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.