Duet 2 Wifi not responding / fried?



  • Hi @ All,

    My Duet 2 Wifi stopped booting and doesnt respond to the erase jumper ...

    Just as i was setting up the Duet 2 Wifi for my printer and started with tuning, my 5V blower fan went bad. I only had a 12V variant at the ready, so I wired that one in, with a 12V buck converter (powered by VIN) and set the Fan voltage to 5V (for the other 5V Hotend Fan). So the 5V HE Fan was just wired directly to the Duet (2 Pin) and the 12V Fan got 12V from the converter and I wired ground to the Duet Fan-. Oh and I'm using 24V as VIN.
    Did I fry my board by doing that? 😧
    I must have overread the warning in the guide for mixed voltage fans to set it to highest fan voltage.

    So to the problem: After doing the wiring and connecting the board to power it never booted. The VIN, 5V, 3,3V LEDs were on but the DIAG LED always off. After that I removed VIN and disconnected the whole Hotend (so fans, heaters, etc. - its all on one plug at the HE). Then I retried with a USB Cable: still no DIAG LED but USB, 5V, 3,3V LEDs. When I tried to erase the FW the 3,3V LED starts flashing. After removing the Jumper the 3,3V LED is very dim and when I press the reset button it lights up but goes to dim again as soon as the button is released. The board also doesnt show up as a COM port or as Bossa Port ...

    Thanks very much in advance for you help 🙂

    Cheers Lukas


  • administrators

    Unfortunately your connection scheme connected the output of the buck regulator through the fan and the flyback diode to the 5V rail. That will in turn have very likely caused the 3.3v regulator to fail and the voltage on the 3.3V rail to be exceeded.

    So some components will have been blown. Start by seeing which components are getting hot. Likely failure points are the SD card (so remove it from its socket), 3.3V regulator, and WiFi module. After that, the processor, and chip U11. The fact that the 3.3V LED goes dim when the reset button is released suggests that the processor has failed.



  • Ok 😞 ... Thanks for the quick answer!

    So: power it by USB and then see which components are getting hot?


  • administrators

    USB or VIN power, it probably doesn't matter which.



  • So I had it powered on for a couple of minutes and nothing gets noticeably hotter ...
    Do I have any other options to check the components for failure?



  • Measure the 3.3v voltage, if its good then odds are you need a new processor as a minimum, if the voltage isn't 3.3v and nothing gets hot then i'd start with the 3.3v regulator and work from there.


Log in to reply