Tronxy X5SA Pro - printing too slow.



  • I'm a noob to 3D printing, but I can't figure out why my printer (Tronxy X5SA-Pro stock with Duet 3) is printing so slow. I checked the M203 line and the values are the same as another forum member. If someone can tell me what I did wrong here, I would appreciate it.

    Thanks

    ; Configuration file for Duet 3 (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Mon May 25 2020 02:12:03 GMT-0400 (EDT)
    
    ; General preferences
    G90                                          ; send absolute coordinates...
    M83                                          ; ...but relative extruder moves
    M550 P"Tronxy X5SA Pro"                      ; set printer name
    
    M667 S1                                      ; select CoreXY mode
    
    ; Network
    M552 P0.0.0.0 S1                             ; enable network and acquire dynamic address via DHCP
    M586 P0 S1                                   ; enable HTTP
    M586 P1 S0                                   ; disable FTP
    M586 P2 S0                                   ; disable Telnet
    
    ; Drives
    M569 P0.0 S1                                 ; physical drive 0.0 goes forwards
    M569 P0.2 S1                                 ; physical drive 0.2 goes forwards
    M569 P0.3 S0                                 ; physical drive 0.3 goes backwards
    M569 P0.5 S0                                 ; physical drive 0.3 goes backwards
    M569 P0.1 S1                                 ; physical drive 0.1 goes forwards
    M584 X0.0 Y0.2 Z0.3:0.5 E0.1                 ; set drive mapping
    ; Dual-Z
    ; Leadscrew positions: The measurement is taken from X=0, Y=0. Therefore X will be negative, Y positive and middle of bed = 165
    M671 X-90:420 Y165:165 S2.0                  ; Leadscrews at middle left and middle right (S is max correction value)
    
    M350 X16 Y16 Z16 E16 I1                      ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E400.0             ; set steps per mm
    M566 X600.00 Y600.00 Z12.00 E120.00          ; set maximum instantaneous speed changes (mm/min)
    M203 X18000.00 Y18000.00 Z180.00 E1500.00    ; set maximum speeds (mm/min)
    M201 X3000.00 Y3000.00 Z100.00 E10000.00     ; set accelerations (mm/s^2)
    M906 X950 Y950 Z950 E950 I30                 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30                                      ; Set idle timeout
    
    ; Axis Limits
    M208 X0 Y0 Z0 S1                             ; set axis minima
    M208 X330 Y330 Z400 S0                       ; set axis maxima
    
    ; Endstops
    M574 X1 S1 P"!io0.in"                        ; configure active-high endstop for low end on X via pin !io0.in
    M574 Y1 S1 P"!io2.in"                        ; configure active-high endstop for low end on Y via pin !io2.in
    M574 Z1 S2                                   ; configure Z-probe endstop for low end on Z
    
    ; Z-Probe
    M558 P1 C"!io3.in" H5 F120 T6000             ; set Z probe type to unmodulated and the dive height + speeds
    G31 P500 X-38 Y-15 Z1.96                     ; set Z probe trigger value, offset and trigger height
    M557 X20:300 Y20:310 S20                     ; define mesh grid
    
    ; Heaters
    M308 S0 P"temp0" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin temp0
    M950 H0 C"out0" T0                           ; create bed heater output on out0 and map it to sensor 0
    M143 H0 S120                                 ; set temperature limit for heater 0 to 120C
    M307 H0 B0 S1.00                             ; disable bang-bang mode for the bed heater and set PWM limit
    M140 H0                                      ; map heated bed to heater 0
    M308 S1 P"temp1" Y"thermistor" T100000 B4138 ; configure sensor 1 as thermistor on pin temp1
    M950 H1 C"out1" T1                           ; create nozzle heater output on out1 and map it to sensor 1
    M143 H1 S280                                 ; set temperature limit for heater 1 to 280C
    M307 H1 B0 S1.00                             ; disable bang-bang mode for heater  and set PWM limit
    
    ; Fans
    M950 F0 C"out7" Q500                         ; create fan 0 on pin out7 and set its frequency
    M106 P0 C"Part Fan" S0 H-1                   ; set fan 0 name and value. Thermostatic control is turned off
    M950 F1 C"out8" Q500                         ; create fan 1 on pin out8 and set its frequency
    M106 P1 C"Extruder Fan" S1 H1 T45            ; set fan 1 name and value. Thermostatic control is turned on
    
    ; Tools
    M563 P0 D0 H1 F0                             ; define tool 0
    G10 P0 X0 Y0 Z0                              ; set tool 0 axis offsets
    G10 P0 R0 S0                                 ; set initial tool 0 active and standby temperatures to 0C
    
    ; Custom settings are not defined
    M501
    
    

  • Moderator

    @catshow Check it's not your slicer program (which are you using? Cura, PrusaSlicer, S3D?) sending motor settings gcode at the start of the print. Post a gcode file that's causing the problem.

    Ian



  • Thanks for responding. This is a BL Touch mount for my printer.

    CFFFP_tronxy_hotend_mount_bltouch.gcode


  • Moderator

    @catshow This is the first few lines of that gcode file:

    ;FLAVOR:RepRap
    ;TIME:851
    ;Filament used: 0.758723m
    ;Layer height: 0.2
    ;MINX:144.2
    ;MINY:147.7
    ;MINZ:0.3
    ;MAXX:185.8
    ;MAXY:182.3
    ;MAXZ:17.9
    ;Generated with Cura_SteamEngine 4.6.1
    T0
    M190 S60
    M104 S200
    M109 S200
    M82 ;absolute extrusion mode
    G28 ;Home
    G1 Z15.0 F6000 ;Move the platform down 15mm
    ;Prime the extruder
    G92 E0
    G1 F200 E3
    G92 E0
    M83 ;relative extrusion mode
    G1 F1500 E-6.5
    ;LAYER_COUNT:89
    ;LAYER:0
    M107 P1
    G0 F3600 X148.623 Y149.849 Z0.3
    ;TYPE:SKIRT
    G1 F1500 E6.5
    G1 F1800 X149.222 Y149.334 E0.03941
    G1 X149.87 Y148.883 E0.03939
    G1 X150.561 Y148.499 E0.03944
    G1 X151.286 Y148.187 E0.03938
    

    Seems fine, and the slicer (Cura) isn't changing motor settings. Print speed for the first layer is set at F1800 which is 30mm/s, and increases to F3600 (60mm/s) for subsequent layers. Are you expecting more that this? If so, increase the speeds in the slicer. Your maximum speeds in config.g should allow higher speeds.

    Ian


Log in to reply