What's the status of Duet2s supporting the RRF3 object model?

  • @dc42 When I try the official 3.1.1 RRF build on a Duet2, a request for rr_model results in
    Your Duet rejected the HTTP request: Unknown request

    If I build from an unmodified v3.01-dev branch which has
    ./src/DuetNG/Pins_DuetNG.h:64:#define SUPPORT_OBJECT_MODEL 1
    I DO get a model.

    Was it disabled in the last release?

  • administrators

    No, it wasn't disabled. You can verify that it supports the object model by using M409, which is the GCode counterpart to rr_model.

  • @dc42 Very weird. I had to flash the board again with the official build and it worked. It's also weird that when I tried to flash it with the official build again, I got an error about not finding Duet2CombinedIAP.bin. It's weird because how could I have gotten the other 3.1.1 builds to flash without it. Hmmm.

    Anyway, problem solved. Thanks.

  • administrators

    @gtj0, I can only think that you were running firmware 3.0 or another older firmware version.

Log in to reply