Duet 2 Wifi non responsiv.



  • I have a relative "dead" Duet 2 WiFi board.

    I've had it for a few months and installed it on my BLV Cube (CoreXY) yesterday.

    Upgraded to 2.05.1 and used the reprap configurator tool creating the config files, all worked perfect and did so for a couple of hours.

    Turned it of late last night.

    Today when I turned it on again, I couldn't get any contact with the board.

    Neither USB nor the web interface seems to be active.

    The LED on the WiFi interface dosn't turn on and it gets very hot fast.

    I tried to read the SD card from the board in a PC, it's not readable. The PC won't recognize it at all.

    I Backed up the SD card yesterday, so tried righting the software to a new SD card - didn't change anything, the board is still nonresponsive.

    There is no visible defects on the board. I checked the 3 fuses all are intact.

    So basically I'm out of ideas!

    Any suggestions?



  • @tom18 said in Duet 2 Wifi non responsiv.:

    The LED on the WiFi interface dosn't turn on and it gets very hot fast.

    getting hot sounds like it has failed, the other LEDs would be of interest. did you follow https://duet3d.dozuki.com/Wiki/What_to_do_if_your_Duet_won't_respond ?

    (I'd skip the step about the erase jumper as long at the wifi module is getting hot)



  • @tom18 said in Duet 2 Wifi non responsiv.:

    erd

    Yes now I have. 😉

    Here is a few pictures of the board.Duet front.JPG Duet LED.jpg
    As you can see all LEDs light up. The DIAG LED stays on - as the WiFi gets very hot i only had it connected for a couple of minutes.
    The reset button is free and seems to be working as it is supposed to.

    Connecting to the PC - No devices is shown - using the same USB port on the computer as i was when I configered the WiFi yeasterday.

    I have not done the erase part. Should I try that?


  • Moderator

    Where and when was it purchased?

    How much did you have wired up before it failed?

    You can try using the erase button but if you can't get it discovered by the PC to reflash it might not make a difference.



  • @tom18 said in Duet 2 Wifi non responsiv.:

    The DIAG LED stays on

    even without the SD card inserted?



  • I got this on in February
    Purchased from Filament23d in DK

    Reset dos not help.

    Wired up was
    x, y and dual z motors
    X ans y end stops - I plan to use a Bltouch as z probe, but I haven’t finished the testing of the conversion to 3,3V - so that’s no connected yet.
    Tool - Hermera. Incl. fans
    Headed bed creality CR-10 pro. Powers through a secondary power sup - mosfeet.
    And the thermistors for both.
    24V power sup.
    Solid stat relays for M80 M81

    Every thing worked perfectly...... for a short time



  • @bearer
    yes


  • administrators

    Are any other components getting hot? In particular, the microcontroller.

    It's worth trying the Erase jumper, so see if you can get the Bossa port to appear on the PC. It looks like there has been a transient on the 3.3v supply, which has blown the WiFi module (and quite likely the SD card too). However, the processor seems to be more robust, and there have been cases before where a transient has blown the WiFi module and corrupted the firmware in the main processor, but it has been successfully reprogrammed.



  • Hi @dc42

    The WiFi module gets extremely hot, fast - but as far as I can tell no other components are getting hot.
    Eras did not change anything - no ports appear on the PC after eras - did it 5 times.

    Forgot one thing in the list of connected items:-)

    I have a PanelDue 7i connected as well.
    it turns on when the board gets power - but no communication with the board as far as I can see.


Log in to reply