DUET WIFI connection problem after firmware updating to 3.0



  • Hello everyone,

    After some attempts to update the firmware of my Duet WIFI I managed to install version 3.0 (it was 2.02).
    The card connects to WIFI only through the USB connection with the M552 S1 command on YAT. From here I can launch DWC and everything seems to be working. The problem arises when I close YAT disconnecting the USB cable to connect via Browser.
    When the board is turned on, the Blue LED does not flash and always remains off, consequently DWC cannot connect.
    I attach some photos hoping they will be useful to understand the problem
    Thanks in advance for any help.
    This is the screenshot of DWC connected with USB Cable and YAT with WIFI activated via M552 S1
    DWC with USB connected and YAT command M552 S1.jpg
    This is the card connected with USB and YAT
    Bouard connected to YAT Via USB cable.jpg

    Thankyou



  • Do you have M552 S1 in your config.g?



  • or a problem in config.g that prevent the firmware parsing the rest of the file and subsequently never reaching the M552?



  • I checked the SD card and I found several config .g files , I think that trying to update the software i did a mess !
    However the M552 S1 command was present in all of them . I deleted the other config files thinking that they could conflict leaving only one of them, but the problem is still there. At this point I ask you if I can clean the SD card, reset everything and reload drives and updates from the beginning...



  • @Sandro said in DUET WIFI connection problem after firmware updating to 3.0:

    several config .g files

    there can only be one /sys/config.g; there can be an config.g.bak and a config-override.g, and possiby other variations, but only one config.g

    if config.g contains M501 it will also execute config-override.g, which there can also only be one of.



  • I understand, but i found config (1), config (2) etc files..
    I think that at this point I will look for a procedure to clean and reload firmware .
    Hope it will not be so difficult..
    Thankyou


  • Moderator

    Now that you have 3.0 installed, you should update to 3.1.1



  • I just did it and everything looks to work , even the modem connecting again.
    I still don't understand what kind of mistake and how many I did, I'm new in this field and I must admit that for me is much more complicated than I thought.
    Thankyou !


  • administrators

    I'm glad it's solved now. Upgrading from RRF 2.x to 3.1.x is unfortunately complicated. Future firmware upgrades will be much simpler for you.



  • @dc42 Thank you


Log in to reply