Print Continuously Pausing After Selecting "Resume Print"



  • Hello everyone! I am having an interesting problem regarding my Duet 2 Wifi.

    For context, I am doing my first large volume print on this particular machine (a heavily modified Ender 5). For a slicer, I use Simplify3d, and it has never failed me (until maybe now?). I even ran a simulation on this gcode file before actually printing it so I could get an accurate print time. The simulation worked flawlessly, giving me a 35 hour estimate.

    Next, I started the print, watched the first couple layers go down, and went to sleep. I woke up about 5 AM and discovered that it was paused. Puzzled, I opened up DWC and found it in fact to be paused. I next pressed resume print, and it went to its resume position on the print. However, before it extruded or moved, it paused again. This is where it gets weird.

    A blank box, similar in size and style to the box that flashes on DWC when a filament sensor pauses the print, came up. The only thing in this box was the word "okay." I selected okay with my cursor, and it went away. At this point, the print tool had moved back to the home position. I pressed resume print again, and everything repeated.

    Can anyone tell me what is going on here?

    Be safe during this pandemic everyone!

    Jordan Stephenson, JD


  • Moderator

    Did you see any error messages in the gcode console?
    Were the temperatures correct?
    Please post your config.g and perhaps the gcode file in question?
    What firmware version adn DWC are you using? What Duet board?
    Do you have a filament sensor?



  • I checked the G Code console and there were no errors reported.

    The temperatures were very stable and correct.

    My config and the gcode file in question are attached.

    RRF 2.05.1 for Duet Wifi 2 1.02 (2020-02-09b1), DWC 3.1.0.

    I have a Duet laser sensor, but it is disabled currently.

    config.g
    config-override.g
    https://1drv.ms/u/s!AmZ7ep7HflN2hIIOYB-I_AEdDtFNGA?e=4GRWye


  • Moderator

    Can you try commenting out the entire sensor line?

    ; M591 D0 P5 C3 R-300:50 E3.0 S0

    Also,

    M574 X1 Y1 S3 F1 R2 ; set endstops controlled by motor stall detection

    I don't think F1 R2 is valid argument for the endstop config.

    https://duet3d.dozuki.com/Wiki/Gcode#Section_M574_RepRapFirmware_2_x_and_earlier



  • Certainly, I will give it a try.

    I deleted that particular gcode file and resaved it. No settings changes, and it worked fine.

    I will go ahead and do the steps you advise.

    Thanks!

    Jordan


Log in to reply