Z axis won't home



  • I recently bought a duet mastero board everything is physically hooked up right to the board I checked the pinout I can home the x and the y but not the z I have endstops for x y and z plus a dc42 ir sensor for z its hooked up and it blinks 4 times with the red
    Led

    • list item


  • Screenshot_20200529-160918_Chrome.jpg


  • Moderator

    Please post your homeall file and your full config.g please.

    Have you gone through this?

    https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe



  • Yes I've gone through everything read everything I got no clue how do I post the whole file



  • ; Configuration file for Duet Maestro (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.1 on Thu May 28 2020 15:58:50 GMT-0400 (Eastern Daylight Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"Seans Printer" ; set printer name

    ; Network
    M552 S1 ; enable network
    m552 p192.168.0.107 ;(0 = DHCP)
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S0 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S1 ; physical drive 2 goes forwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X100.00 Y100.00 Z400.00 E415.00 ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X15000.00 Y15000.00 Z120.00 E1020.00 ; set maximum speeds (mm/min)
    M201 X1000.00 Y1000.00 Z4.00 E750.00 ; set accelerations (mm/s^2)
    M906 X1600 Y1600 Z1600 E1600 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X200 Y200 Z200 S0 ; set axis maxima

    ; Endstops
    M574 Y1 S1 ; set active high endstops
    m574 X2 S1 ; set active low endstops
    M574 Z1 S1 ; set endstops controlled by probe

    ; Z-Probe
    M558 P0 H5 F120 T6000 ; set Z probe type to modulated and the dive height + speeds
    G31 P500 X0 Y0 Z2.5 ; set Z probe trigger value, offset and trigger height
    M557 X15:200 Y15:200 S20 ; define mesh grid

    ; Heaters
    M307 H0 B0 S1.00 ; disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4138 R2200 ; set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R2200 ; set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined


  • Moderator

    So what actually happens and what/how are you trying to get it to do it?

    That document I linked describes how to test the Zprobe. How far do you get?

    @bigwood247 said in Z axis won't home:

    ; Z-Probe
    M558 P0 H5 F120 T6000 ; set Z probe type to modulated and the dive height + speeds
    G31 P500 X0 Y0 Z2.5 ; set Z probe trigger value, offset and trigger height
    M557 X15:200 Y15:200 S20 ; define mesh grid

    From your config.g it looks like you have manual probing enabled and not your IR probe. M558 P0 is for manually moving the nozzle down to the bed. For the IR probe change this to P1.

    In G31 you need to specify an X and Y offset from the nozzle. That's also described in the link.

    If you can post your homeall.g I can tell you how it's trying to home. It may not be set to use the probe at all based on what was in the config.g.



  • I just changed it to 0 recently I was thinking of going that route just to get it work but when I had that at 1 iti tried to home x good home y good but I have the dc42 sensor s out one to the boards in pin the 42 sensors vcc hooked up to the boards 3.3v pin the 42ir grounds hooked up to boards ground and the and 42s out in the boards in ( this is the boards x prob input btw)
    But I also have a manual z endstop hooked up at the same time but I cant even get the dc42 prob to register it has something underneath it all it does when I connect it is blind once then 4 quick blinks it won't trigger if I cant get it working can I set it up just to do manual bed leveling with a reg 2 wire endstop



  • Sorry for the typos I was trying to say I have the dc42s vcc hooked up to the 3.3v connect of the board the42s out to the in of the board and the ground of 42 to the boards ground



  • I was thinking of just writing a new config file and starting over with just manual bed leveling
    Ut in the reprap config tool I can't find a way to set it up for manual



  • Also I might add that I dropped the sensor once before I wired it up



  • So I started from scratch and just set it up with manual bed leveling for now I can always buy another dc42 ir sensor and set it up in a few days


Log in to reply