Duet 2 WiFi error: unknown temperature sensor channel



  • Hi all,

    This is my first post to the forum, as I have generally been able to use your advice to resolve my many issues with the Duet so far.

    The latest in my long series of problems happened yesterday, and I dont know how to resolve it. I had finally managed to get my motors at least moving, and decided to add my extruder (which I had working previously). When I set the extruder to heat I got the message "Error: Temperature reading fault on heater 1: unknown temperature sensor channel" and the current temp was reading as 2000.0 C. I captured a screenshot below.

    Error Screenshot

    I have tried different thermistors and heaters, and have also tried the different heater ports etc, but no joy.

    Below is a sanitized copy of my config.g file (if it helps):


    ; Configuration file for Duet WiFi (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.1 on Mon Jun 01 2020 18:34:28 GMT+0100 (British Summer Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"*****" ; set printer name

    ; Network
    M551 P"*****" ; set password
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S1 ; enable FTP
    M586 P2 S1 ; enable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S0 ; physical drive 2 goes forwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z4000.00 E837.00 ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z250.00 E250.00 ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X230 Y210 Z200 S0 ; set axis maxima

    ; Endstops
    M574 X1 S1 P"xstop" ; configure active-high endstop for low end on X via pin xstop
    M574 Y1 S1 P"ystop" ; configure active-high endstop for low end on Y via pin ystop
    M574 Z1 S1 P"zstop" ; configure active-high endstop for low end on Z via pin zstop

    ; Z-Probe
    M558 P0 H5 F120 T6000 ; disable Z probe but set dive height, probe speed and travel speed
    M557 X15:215 Y15:195 S20 ; define mesh grid

    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0 ; create bed heater output on bedheat and map it to sensor 0
    M307 H0 B1 S1.00 ; enable bang-bang mode for the bed heater and set PWM limit
    M140 H0 ; map heated bed to heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M308 S1 P"e0temp" Y"thermistor" T100000 B4138 ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1 ; create nozzle heater output on e0heat and map it to sensor 1
    M307 H1 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit

    ; Fans
    M950 F0 C"fan0" Q500 ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H-1 ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500 ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H1 T45 ; set fan 1 value. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings
    M575 P1 B57600 S1 ;Set paneldue baud rate (57600)


    I really am hoping someone can help me as I am fast approaching the end of my patientlce with this board. I don't mind a learning curve, but I just seem to keep going from one problem to the next. I even had to do some troubleshooting to join the forum and make this post 😊

    I look forward to hearing from you!


  • Moderator

    How do you have things currently connected to the board?

    Your config.g looks ok provided you're actually using RRF3. Can you send M115 in the console to see the currently installed firmware version?



  • Thanks for responding!

    After reading your post I ran M115 and found something quite interesting. Yesterday, I upgraded the Duet to firmware 3.1.1, or so I thought; running M115 I can see that the firmware is actually 2.05.1:

    Duet2_M115.png

    I also noticed my Paneldue was showing the following after I tried to upgrade to 3.1.1 again today:

    20200603_141430.jpg

    The upgrade hasn't worked, and I am confused about the paneldue constantly showing 'Connecting'...

    Do I need to reset the board or do something differently?

    Also, forgive the mess, but this is the current wiring state (i have removed endstops to make the picture clearer):

    20200603_141420.jpg


  • Moderator

    @Harrynice Upgrade to RepRapFirmware 3.0 first, then to 3.1.1. Due to the size of the firmware, the in-app-programmer (IAP - which writes the new firmware over the old firmware while the board is running) needs to be updated by doing this intermediate step. This is also explained in the update notes (See "Upgrading to this release from RepRapFirmware 2.x" here https://github.com/Duet3D/RepRapFirmware/releases/tag/3.1.1 ) :

    Users of RepRapFirmware 2.x cannot upgrade directly to this release because the binaries for the Duet 2 series are too large for the Duet 2 IAP programs. So you must upgrade to RepRapFirmware 3.0 first, then you can upgrade immediately to version 3.1.1. Alternatively, you can use Bossa over USB to upgrade directly to RepRapFirmware 3.1.1 but in this case you will need to upload DWC 3.1.1 and the appropriate IAP file separately.

    RepRapFirmware 3.0 is here: https://github.com/Duet3D/RepRapFirmware/releases/tag/3.0
    You should be able to upgrade just by uploading file Duet2and3Firmware-3.0.zip into /sys on the SD card via Duet Web Control, then do the same again (after it's updated) with 3.1.1.

    Ian



  • Amazing! It is now working again! Thank you so much for pointing this out - I could have sworn I did the upgrade to 3.0.0 first, but apparently not!

    Looks like PEBKAC and issue now appears to be solved, so please accept a virtual beer from me :).


Log in to reply