3.1.0 Tool and Bed Temperature Drop Downs Don’t Work



  • Moved my Railcore from 3.01 to 3.1 and DWC the same. The drop downs for temperature don't work. Nothing happens when I click on them. When I revert to old dwc using the button, it works properly. I went through the release notes but didn't see anything.
    Any help much appreciated!


  • Moderator

    Please update to 3.1.1 and see if the behaviour is the same.

    Also, I'm not exactly sure what behaviour you're talking about. Is the tool selected?



  • @Phaedrux I went to 3.1.1 and same thing. Tool is sekected, both bed and tool show active, but when I click on temp dialog to bring up list of temps to select from, it does nothing. Same for bed or hot end.
    If I revert to old dwc, the temp dialog boxes work properly.



  • @Phaedrux or anyone else experiencing this?



  • I went from 2.04 to 3.1.1, no issues. The drop downs work fine for me. You might check to see if there are actually values to use in the drop down. They are configurable. Look in Machine-Specific->List Items



  • Yes there are values. As I said when I revert to the old DWC interface it works fine. All the temp values are selectable in the pull downs.



  • Just wanted to say this was resolved. I don’t know why I hadn't tried this but I hit the Reset to Default button in DWC and it cleared up the problem.
    I would tag this Solved but don't know how to.


  • Moderator

    @4lathe Topic tools > ask as a question, then topic tools again and mark as solved.


Log in to reply