Warning: Motor Phase B disconnected reported by driver(s) 1



  • I am using a Duet 2 Ethernet with RepRapFirmware version 2.03.

    I get the error "Warning: Motor Phase B may be disconnected reported by driver(s) 1" whenever I use the G1 or G0 commands to move on the y-axis, where the motor is plugged in. (ie. G1 Y100)

    The board is only connected to my computer through the USB port, a 12V power supply, Ethernet, and a motor at the Y-axis motor location on the board.

    === Diagnostics ===<LF>RepRapFirmware for Duet 2 WiFi/Ethernet version 2.03 running on Duet Ethernet 1.02 or later<LF>Board ID: 08DGM-917NK-F2MSW-6JKFL-3S86R-1W5WF<LF>Used output buffers: 1 of 24 (13 max)<LF>=== RTOS ===<LF>Static ram: 25680<LF>Dynamic ram: 92912 of which 0 recycled<LF>Exception stack ram used: 384<LF>Never used ram: 12096<LF>Tasks: NETWORK(ready,524) HEAT(blocked,1236) MAIN(running,4016) IDLE(ready,160)<LF>Owned mutexes:<LF>=== Platform ===<LF>Last reset 16:18:24 ago, cause: software<LF>Last software reset at 2020-06-09 18:14, reason: User, spinning module GCodes, available RAM 11984 bytes (slot 0)<LF>Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x04433000 BFAR 0xe000ed38 SP 0xffffffff Task 0x4e49414d<LF>Error status: 0<LF>Free file entries: 8<LF>SD card 0 detected, interface speed: 20.0MBytes/sec<LF>SD card longest block write time: 14.2ms, max retries 0<LF>MCU temperature: min 31.0, current 33.8, max 34.9<LF>Supply voltage: min 1.6, current 2.0, max 12.9, under voltage events: 2, over voltage events: 0, pow[Warning: Maximal number of bytes per line exceeded! Check the EOL (end-of-line) settings or increase the limit in the advanced terminal settings.]

    I would appreciate any help to resolve this issue.


  • Moderator

    @AstroDoug Please post your config.g , so we know what speeds you're trying to move the motor at. Also, has the motor worked previously? Have you tried connecting another motor to the Y axis? Have you tried connecting the motor to a different axis? Does the motor do anything when you try to move it?

    However, most likely is that there's a wiring problem, and either the motor has a loose wire connection, or is wired incorrectly. Test the motor, ideally with a multimeter, identify the phases, and check the plug is wired in the correct order for the Duet. See https://duet3d.dozuki.com/Wiki/Choosing_and_connecting_stepper_motors#Section_Using_the_internal_drivers

    Ian


Log in to reply