Duet 2 Ethernet and Duex 5 Issues



  • Hi there,

    I've been having a couple of issues with a Duet 2 Ethernet and Duex 5. I was told I need to post here in this forum; I didn't see any categories that would be specific to this so far as I could tell, so if this is posted in the incorrect place, please move it as needed!

    Details about the issues/troubleshooting steps I took are as follows:

    The issues that I'm having are that the ethernet daughter board on the Duet 2 does not seem to be functioning at all. Additionally, the Duex 5 does not seem to be communicating with the Duet Ethernet board. The main symptoms in question here are that the ethernet board does not show up on my network, and the LEDs on the ethernet daughterboard do not turn on to indicate any kind of connection. On the Duex 5, the motor drivers will not energize the motors at all.

    I spent a couple of hours troubleshooting this yesterday, during pretty much all of this time I was speaking with poofjunior/other members of the Jubilee 3d Printer discord server. They helped me verify that my config.g was correct, and that I had the required scripts for homing the Z axis motors, to ensure that it wasn't an issue of firmware configuration. If anyone is curious as to what my firmware config was, it was copied directly from the Jubilee repo on github, and placed into the proper folders on the SD card.

    Here are the things I've tried/checked:

    For the ethernet board, I have set up both a static IP and DHCP to try to have the Duet board show up on my network. I tested this after trying two different ethernet cables, both of which were verified as working on a separate computer. I also hooked up the Duet ethernet board to my computer via USB (After disconnecting 24V power, to avoid a ground loop issue) In doing so, I ran M552 which initially indicated that the network was disabled on the Duet board. To fix that, I ran M552 S1, after which the duet board reported that the network was enabled. I subsequently ran a plain M552 to check, and the board indicated that the network should indeed have been active. However, I still saw absolutely no indication of a connection through the ethernet port on my Duet, nor could I find the duet board on my home network when looking through my router's "attached devices" page. I tried the same above at least two or three times, power cycling the board each time.

    As for the Duex 5 board, I have 3 Z axis motors connected for a Jubilee printer. The ribbon cable is correctly oriented and securely seated in both boards, and the ribbon cable itself appears to be in good working order. The Duex 5 is getting power, which I've checked at both the screw terminals, and the led/fan ports. Both register 24.4V, which is coming from my Meanwell Power supply. The Duex 5 is connected to the Duet 2 Ethernet in exactly the way that Duet recommends in its documentation - I am using 16AWG stranded wire that has been crimped into the provided Duet ferrules very securely. The Duet 2 has a double connection, so the power supply routes into the Duet 2, then goes down to the Duex 5, and the polarity is correct.

    To rule out any issues with the motors themselves, I plugged the Z axis motors into the X axis driver on the Duet Ethernet board. They all moved just fine when attempting to home X.

    After checking the motors, I ran M122 several times. The first time I ran it with USB connected to my computer through Simplify3D, with 24V power off. The second time I ran it, I disconnected my laptop from the wall to avoid a ground loop issue, on the off chance that the Duex 5 needed the 24V power to be operational. The third time I ran M122 was with the PanelDue I have connected to the Duet 2 Ethernet board.

    All outputs were identical, and as follows:

    SENT: M122
    READ: === Diagnostics ===
    READ: RepRapFirmware for Duet 2 WiFi/Ethernet version 2.03 running on Duet Ethernet 1.02 or later
    READ: Board ID: 08DLM-996RU-N8PS0-7J9D8-3S86N-1B8HN
    READ: Used output buffers: 1 of 24 (10 max)
    READ: === RTOS ===
    READ: Static ram: 25680
    READ: Dynamic ram: 93576 of which 108 recycled
    READ: Exception stack ram used: 312
    READ: Never used ram: 11396
    READ: Tasks: NETWORK(ready,2044) HEAT(blocked,520) MAIN(running,3792) IDLE(ready,160)
    READ: Owned mutexes:
    READ: === Platform ===
    READ: Last reset 00:01:24 ago, cause: power up
    READ: Last software reset time unknown, reason: Heat task stuck, spinning module Platform, available RAM 11048 bytes (slot 3)READ: Software reset code 0x00a0 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0041f80f BFAR 0xe000ed38 SP 0x200049ac Task 0x4e49414d
    READ: Stack: 0044ce71 004031cc 21000000 3f800000 00000000 00000000 c0000000 3331bb4c 41100000 3e178897 3e1cd04f 3db479aa 3e3a357c 3e639095 3e924a95 3bfe76a2 395debbd 3f800000 3f800000 20000010 004031bd 00429710 61000000READ: Error status: 0
    READ: Free file entries: 9
    READ: SD card 0 detected, interface speed: 20.0MBytes/sec
    READ: SD card longest block write time: 0.0ms, max retries 0READ: MCU temperature: min 41.0, current 41.4, max 41.6
    READ: Supply voltage: min 24.3, current 24.3, max 24.4, under voltage events: 0, over voltage events: 0, power good: yes
    READ: Driver 0: standstill, SG min/max not available
    READ: Driver 1: standstill, SG min/max not available
    READ: Driver 2: standstill, SG min/max not available
    READ: Driver 3: standstill, SG min/max not available
    READ: Driver 4: standstill, SG min/max not available
    READ: Date/time: 1970-01-01 00:00:00READ: Cache data hit count 164285038READ: Slowest loop: 1.40ms; fastest: 0.08ms
    READ: I2C nak errors 0, send timeouts 0, receive timeouts 0, finishTimeouts 0, resets 0
    READ: === Move ===
    READ: Hiccups: 0, FreeDm: 169, MinFreeDm: 169, MaxWait: 0ms
    READ: Bed compensation in use: none, comp offset 0.000
    READ: === DDARing ===
    READ: Scheduled moves: 0, completed moves: 0, StepErrors: 0, LaErrors: 0, Underruns: 0, 0
    READ: === Heat ===
    READ: Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    READ: Heater 1 is on, I-accum = 0.0
    READ: === GCodes ===
    READ: Segments left: 0
    READ: Stack records: 1 allocated, 0 in use
    READ: Movement lock held by null
    READ: http is idle in state(s) 0
    READ: telnet is idle in state(s) 0
    READ: file is idle in state(s) 0
    READ: serial is ready with "M122" in state(s) 0
    READ: aux is idle in state(s) 0
    READ: daemon is idle in state(s) 0
    READ: queue is idle in state(s) 0
    READ: autopause is idle in state(s) 0
    READ: Code queue is empty.
    READ: === Network ===
    READ: Slowest loop: 0.29ms; fastest: 0.00ms
    READ: Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    READ: HTTP sessions: 0 of 8
    READ: Interface state 0, link down
    READ: ok

    If you have any further troubleshooting suggestions, please let me know! I'm happy to try anything that might get this up and running without having to send it back in for replacement. I am also unsure if the issue is solely with the Duet 2 Ethernet board, or both the Duet 2 Ethernet and the Duex 5.

    Thanks!


  • administrators

    Please send M115 and check whether the response includes "+ DueX5". If it doesn't, then the Duet isn't seeing the DueX5. This can be caused by the 50-way ribbon cable not being plugged in securely to both boards, or by a faulty ribbon cable. However, the most common reason is a particular intermittent fault on the DueX5. So if the ribbon cable is securely plugged in at both ends, please return the DueX5 and ribbon cable to your supplier.

    The Ethernet is a separate issue. Make sure that you have enabled the network using M552 S1 (which you can do in config.g) and verify it is enabled by sending M552 (as you have done). Then try connecting it to different devices (e.g. router, or Ethernet port on a laptop or PC) using different Ethernet cables, to see if you can get the link LEDs to light up on the Ethernet sockets of the Duet and the other device. Once you have the link LEDs lit, we can look at configuring the Duet to make it visible on the network.


Log in to reply