E1 heater always on



  • I dont know what caused it but my e1 heater is always on, i have tryed removing the sd card, no change.

    What can i do?
    Is my board fried?
    do i have to buy a new one?



  • @frasse said in E1 heater always on:

    i have tryed removing the sd card, no change.
    What can i do?
    Is my board fried?

    board is probably okay but the E1 mosfet is probably fried.

    options: replace mosfet or use external mosfet



  • @bearer thanks i will try that



  • forgot to add the common cause is a short in the heater wire causing a short circuit current that exceed the mosfet rating, and the fuses are usually only fast enought to protect against over loads, not short circuits.

    ( if replacing the mosfet is an issue I'd reccomend an external one, but you could always see if you have a friendly neighbourhood nerd willing to help, and this thread https://forum.duet3d.com/topic/13875/community-repairs?_=1592354126165 )



  • Thanks again

    Do you know witch one of the mos fets that is for heater 1 and mayby the values?
    How wuld i go about to use an external mosfet?



  • Hi... If i Send you my duet can you change the mosfet?
    Alsow it looks like something is wrong with the pwm fan outputs, only fan 2 is responding, there is curent flowing on the other two chanels but no mater what procentige im running they wont drive a fan.



  • @frasse said in E1 heater always on:

    If i Send you my duet can you change the mosfet?

    if you're in norway and can wait a couple of weeks, sure. I have a cast on one hand so pretty limited in what I can do atm, and sending anything from abroad is very costly due to new custom rules (not to mention slow due to the pandemic)



  • @frasse said in E1 heater always on:

    only fan 2 is responding,

    sounds like you might have shorted out more than the heater, is the fans that are failing also on the hot end? if so you should really examine your wiring to find out what caused the failure.

    and a picture of the board may help spot more faults.



  • Sorry about your hand. I live in Sweden, Stockholm and because of the pandemic im not able to come to Norway any time soon 😞

    IMG_15322.jpg

    I believe the short circuit that caused all this was do to me using wrong type of dc power jacks on my carriage and that current flue thru the frame of my printer, i have removed all connectors of this type and i'm searching for better ones.

    Iv buzzed the mosfets and the one in the lower right corner seams to be always open, i assume that is the bad one.
    When plugged in the upper mosfet has VIN current at drain meanwhile the lower shows no current on any pin, does that help?



  • @frasse said in E1 heater always on:

    Iv buzzed the mosfets and the one in the lower right corner seams to be always open, i assume that is the bad one.

    not sure what you mean by always open, but the failed one will have a short between source and drain, always conducting. (from the schematic E1 uses TR8, so that will be the lower one)

    (the fan connector obscured the view of the tiny mosfets for the fans btw, you'd likely see similar results on TR5 and TR9 for the fans)



  • OK Thanks
    I believe i can get help acquiring and replacing the components at work now that i now witch components to replace.


Log in to reply