Unable to update Duet3



  • My brand new Duet3 is doing some weird things. It powered on perfectly and connected to my SBC however the config file didn't seem to work with multiple errors showing when booting (reporting errors with commented out titles etc.) one of which was a firmware incompatibility. It clearly was communicating because I could adjust the only connected fan just fine. I had updated my DuetPi as soon as it booted the first time however the firmware was still at 3.0 Beta12 when checked with an M115. I tried to upgrade it through the web interface but it failed and said to use the BOSSA system. Unfortunately neither of my computers see the port and instead get a "unable to reset USB device" error.

    Any ideas?

    Greg



  • sounds like you missed the part where whats_new.md says you need to update to 3.0 first the, to the latest 3.1.1?

    did you erase the board with the jumper (or my preffered way sending M999 P"ERASE" via usb when the old firmware is still running).

    if you can connect the Duet's micro usb to the Pi then running wget https://pastebin.com/raw/Wa1kYf3G -O - | tr -d "\r" | bash should in theory set up bossac and flash the firmware that is part of software on the Pi for you.



  • Thanks!. That failed for me too however my board decided it felt like talking to my laptop now so it accepted a flash of the 3.0 firmware. No idea why it decided to work but it did and that's all that matters right?



  • Some user are seeing issues getting connected to the bootload with the duet3, with other cables or computers sometimes being the solution.

    But yes, once you're on 3.0 you should be able to update to 3.1.1.

    simplet is probably to run M997 in DWC (or via usb serial if DSF/DWC doesn't work yet)

    (edit: or with bossa the interim step of 3.0 doesn't apply, its a limitation of the iap firmware which is bypassed with bossa)


Log in to reply