Duet 3 3HC Expansion Board Output issues



  • Hi Everyone,
    I am in the middle of the preliminary tests of my printer and I got issues.
    My config is:

    -Duet 3 Mainboard 6HC
    -Expansion Board 3HC

    I am already using (with success) all the large output on the mainboard (Out0 to Out3) and I need to use the Out 0, Out 1 and Out 2 of the expansion board (only 1) to drive SSR. With the mainboard's outputs, the SSR turn on with no issue. But with the Expansion's out, I have 24V on the relay but none of them trigger.
    I already swapped SSR and output, it seems that only the expansion's out are behaving like this.
    Does anybody knows if the way i set it up doesn't work ?
    Thank you in advance for your answers

    See my config.g:

    ; Heaters
    M308 S0 P"0.spi.cs1" Y"rtd-max31865" ; configure sensor 0 as thermocouple via CS pin spi.cs0
    M950 H0 C"0.out1" T0 ; create bed heater output on out0 and map it to sensor 0
    M307 H0 B1 S1.00 ; enable bang-bang mode for the bed heater and set PWM limit
    M140 H0 ; map heated bed to heater 0
    M143 H0 S280 ; set temperature limit for heater 0 to 280C
    M308 S1 P"0.spi.cs0" Y"rtd-max31865" ; configure sensor 1 as thermocouple via CS pin spi.cs1
    M950 H1 C"0.out0" T1 ; create nozzle heater output on out1 and map it to sensor 1
    M307 H1 B0 S1.00
    M143 H1 S450 ; disable bang-bang mode for heater and set PWM limit
    M308 S2 P"0.spi.cs2" Y"rtd-max31865" ; configure sensor 2 as thermocouple via CS pin spi.cs2
    M950 H2 C"0.out2" T2 ; create nozzle heater output on out2 and map it to sensor 2
    M307 H2 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit
    M308 S3 P"1.spi.cs2" Y"rtd-max31865" ; configure sensor 3 as PT100 on pin 1.spi.cs2
    M950 H3 C"1.out2" T3 ; create nozzle heater output on 1.out2 and map it to sensor 3
    M307 H3 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit
    M308 S4 P"1.spi.cs1" Y"rtd-max31865" ; configure sensor 4 as PT100 on pin 1.spi.cs1
    M950 H4 C"1.out0" T4 ; create nozzle heater output on 1.out0 and map it to sensor 4
    M307 H4 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit
    M308 S5 P"1.spi.cs0" Y"rtd-max31865" ; configure sensor 5 as PT100 on pin 1.spi.cs0
    M950 H5 C"1.out1" T5 ; create nozzle heater output on 1.out1 and map it to sensor 5
    M307 H5 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit

    ; Fans
    M950 F0 C"out7" Q500 ; create fan 0 on pin out7 and set its frequency
    M106 P0 S0 H-1 ; set fan 0 value. Thermostatic control is turned off

    ; Tools
    M563 P0 D0 H1:4 F-1 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C
    M563 P1 D1 H2:3:5 F0 ; define tool 1
    G10 P1 X0 Y0 Z0 ; set tool 1 axis offsets
    G10 P1 R0 S0 ; set initial tool 1 active and standby temperatures to 0C


  • administrators

    1. Use M115 to check that you are running firmware 3.1.1 on the main board and 3.1.0 on the expansion board.
    2. Run M98 P"config.g" to check whether any errors are reported.

Log in to reply