Duet 3 DCS not starting and unresponsive Duet



  • Hi:

    I have a duet 3 and pi. I updated the sd card on the Pi following instructions to format the card properly, balena to load the newest I am getting a DCS not working message when I try to connect. duet error.PNG

    Also note that the duet turns on, but I am not sure it is responsive. No blinking lights but it does power up20200707_172426.jpg

    Thanks in advance for any help.

    Mark



  • Can you send M115 to the Duet's usb serial console and see what it responds? Odds are the firmware is out of date on the board compared to the DSF software on the pi.

    Also run journalctl -fu duetcontrolserver on the Pi and share it here.



  • Here is the log from the pi:

    duet log.PNG

    no connection via serial port- I couldn't get windows to recognize the USB com. Same with bossa



  • hm, status of the red DIAG LED? i think it is between micro sd slot (which should be empty) and the reset button micro usb port.

    and can you see if you can try a couple of different micro usb cables between the pi and the duet, run lsusb for each one.



  • Here are logs with 3 different micro usb cables:lsusb results.PNG

    Diag LED is dimly lit: 20200708_073227.jpg



  • Imo either the USB cables it the Duet3 is bad. Wait and see if the Duet ppl want you to try erasing the board to get it into programming mode?



  • Thanks for the feedback. I tested the USB cables on other devices and they work.
    I don't know where to go at this point. Any suggestions are appreciated.


  • Moderator

    Do you have a powered USB hub you can put between the duet and your PC?



  • I do have a powered hub. I have tried plugging the usb to the duet from my desktop through the hub and the diag led is the same dim result


  • Moderator

    When and where did you purchase the Duet 3? You can contact your reseller and initiate a warranty return. Reference this forum thread as authorization.

    https://www.duet3d.com/warranty



  • I got it from Filastruder, December of last year.



  • What’s it look like if you don’t have the usb on the Duet connected to anything? You don’t need it at all for it to work. What Vin are you supplying the Duet, how is the Pi being powered and how are 5v jumpers set on the Duet? Also, no as card in the Duet, correct?

    Edit: I see no sd card in the Duet, you should only have one in the pi. Looks like you have 5v enable and Duet —> SBC set. All you should need is the ribbon cable between the Duet and Pi. I’d pull the usb cable and confirm the 26 pin cable is connected correctly. DCS is complaining the transfer pin isn’t ready.



  • @gt40 said in Duet 3 DCS not starting and unresponsive Duet:

    December of last year.

    Thats a while ago, has it worked before now?

    Diag LED is dimly lit:

    Does this change momemtarily when you press the reset button on the board?


    If it was my board, I'd place a jumper on the erase pins for a few seconds to see if that made the board show up as a bossa programming port as described in the docs. But, on the off chance there is a problem with USB (be it cables/computer/duet) and the board actually has the firmware loaded that should be the very last step.



  • Trying the erase jumper multiple times and no bossa port shows. Also hit the reset button - no change in the diag led. Turning on the Duet without any usb had no change. I only plugged in the usb to try to connect via serial for bossa. Before when it worked, the ribbon cable was connected to the Pi only. I checked the 26 pin cable but it was not unplugged from when it worked.



  • Sounds like something has failed. I'd disconnect everything from the Duet and test it according to https://duet3d.dozuki.com/Wiki/What_to_do_if_your_Duet_won't_respond (its written for the Duet2, but in in broad terms it'll be the same with the Duet3 except the Diag LED should flash at about 1hz when the firmware is working normally)

    If still dead then, I'm afraid its not looking very promising.

    edit:

    Before when it worked, the ribbon cable was connected to the Pi only

    just to clarify - ribbon was not connecting the Duet to the Pi before, it just had the 40pin side connected to the Pi and the 26pin side floating somewhere? (or that the ribbon was the only connection between the two? makes more sense)



  • You are correct, when it worked before the ribbon was the only connection between the pi and the duet



  • This post is deleted!


  • This post is deleted!


  • Now for what I had intended to post here...

    While I suspect the Duet is the issue, if it works when everything is disconnected as pr above you can refer to this thread on how to test if the pins on the pi are working as they should. But I wouldn't spend any time on that before you have a Duet board with a steady 1hz flashing red DIAG LED.


Log in to reply