UNSOLVED Duet2 Wifi Overvoltage issue



  • I've been running a Duet2 Wifi successfully for about 2 years. After not using it for about 3 weeks, I tried a simple calibration square the other day and got a 'VIn' error. At startup, it will read about 24V and slowly creep up over a few minutes to about 30V. A multimeter reading of the supply inputs to the duet is 24.9V, but the webportal reads the VIn as ~29V. All LEDs (VIn, +5, +3, wifi signal) are lit; pin 41 (ADVREF) on the expansion header is 3.28V, as is pin 43 (+3.3V). I've tried unplugging all wires but VDC, and the problem is still there. All other readings (Temps, positioning) I can get from the webportal appear fine as well.
    Any suggestions would be appreciated.


  • administrators

    The 3.3V rail is used as the voltage reference for measuring VIN. So most likely, the 3.3V rail is dropping. Is the 3.3V regulator getting hot?



  • Not from what I can tell. Nothing seems warm or looks damaged. I live in a very humid climate, but have checked all ICs and traces for corrosion or bridging from bits of debris



  • Checked the U2 regulator, and it's outputting a solid 3.28V with and without all other components plugged in. For reference, the VIn reading from the webportal is now hovering around 31V at rest, so I'm not too keen on leaving the board powered on for too long for fear of frying anything. Aside from the high readings, all other components seem to work: bed and chamber heaters, endstops (x3), wifi, and SD card.



  • After letting it sit (got busy), I tried it again this afternoon and got a solid 24V. I printed a very good calibration square without any issues. However, an hour later when uploading a model, it started reading 29-32V, occasionally dropping back to 24. Same good values at the input and on the 3V regulator



  • Tried an alternate power supply (12V), and got ~20-22V on webportal Vin, so it's obviously a voltage regulation issue. Aside from the U2 3V regulator, does anyone know what could be going bad? I'm still getting solid 3.3V from U2, as well as pins 41 & 43.


  • Moderator

    Curious what firmware version.

    Are you getting any warning messages in DWC?


  • administrators

    It sounds like an issue with one of the following:

    1. The voltage divider that is used to measure VIN. It's just 3 passive components: R80, R81, C79. Try measuring the voltage across R81 or C79. It should be 1/11 of VIN.
    2. The soldering of the microcontroller analog input pin to the PCB. It's pin 41 of the microcontroller. The voltage on that pin with respect to ground should be the same as the voltage across R81/C79.
    3. A problem with the ADC in the microcontroller.


  • Thanks all for the assist. Just got a chance to check references, and all (unfortunately) read within spec: with a 12.14V input, I'm getting R81: 1.046V and R79: 1.04V; R80 is 10.48. Looks like I'll need a new board. At least they're back in stock...


  • administrators

    It's worth checking that the voltage on the VREF pin of the expansion connector is 3.3V, if you haven't done that already. That's the reference voltage to the ADC.


Log in to reply