mgn an8 config issues .



  • ok so i got the duet2 wifi but having a few issues . my motor are original anet motors . 42shdc3025-24b
    here is my config file as well . i used the anet a8 on the config tool . defaults most of the way thru . my issue is that my z motors seem to run fast and one turn then a sec later the other . and it like steps up instead of at the same time . one motor turns a little then the other . i have removed the jumpers and ran the z motors one each socket on the board
    what am i doing wrong . my ends tops work and with the wiring as per the diagram . they x and y i think are reversed
    how do i change them to go the right direction and then fix my z to run smooth at the same time ?
    8ffd0cf7-94d2-4848-a81a-a7834210e5fd-image.png


    ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.4 on Wed Jul 22 2020 12:55:20 GMT+0300 (Arabian Standard Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"Anet A8" ; set printer name
    M669 K1 ; select CoreXY mode

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S0 ; physical drive 2 goes backwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z4000.00 E420.00 ; set steps per mm
    M566 X600.00 Y600.00 Z18.00 E300.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X1500.00 Y1500.00 Z100.00 E10000.00 ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X-33 Y-10 Z0 S1 ; set axis minima
    M208 X220 Y220 Z240 S0 ; set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 S0 ; set active low and disabled endstops

    ; Z-Probe
    M558 P0 H5 F120 T6000 ; disable Z probe but set dive height, probe speed and travel speed
    M557 X20:200 Y20:200 S40 ; define mesh grid

    ; Heaters
    M307 H0 B0 S1.00 ; disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4725 C7.060000e-8 R4700 ; set thermistor + ADC parameters for heater 0
    M143 H0 S130 ; set temperature limit for heater 0 to 130C
    M305 P1 T100000 B4725 C7.060000e-8 R4700 ; set thermistor + ADC parameters for heater 1
    M143 H1 S300 ; set temperature limit for heater 1 to 300C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined

    ; Miscellaneous
    M575 P1 S1 B57600 ; enable support for PanelDue
    T0 ; select first tool



  • Moderator

    @morf33 said in mgn an8 config issues .:

    M92 X80.00 Y80.00 Z4000.00 E420.00 ; set steps per mm

    I think your Z steps per mm are wrong, so the motors are trying to turn too fast. From this thread https://forum.duet3d.com/topic/15206/anet-a8-tuning-issues it should be Z400, not Z4000. So change the above line to:

    M92 X80.00 Y80.00 Z400.00 E420.00       ; set steps per mm
    

    Looking at your other settings, they seem to be the defaults. I'd guess that your M92 line should actually be:

    M92 X100.00 Y100.00 Z400.00 E100.00       ; set steps per mm
    

    Have a look at this thread, has example config: https://forum.duet3d.com/topic/5843/anet-a8-stepper-motor-question
    A forum search for 'Anet A8' https://forum.duet3d.com/search/?term=anet a8&in=titlesposts brings up a number of other threads that may be useful too.

    Ian


Log in to reply