Online configurator selecting wrong z.probe mode



  • Pretty sure this isn't the correct place, but didn't know what is.
    What I did:

    • connect NPN capacitive sensor to z.probe-in
    • in configurator I selected z.probe-in as the signal pin
    • in the endstop tab, I selected "switch" as the z probe type

    Issues:

    • selecting "switch" type shows you information that says the probe must be connected to the e0 stop pin
    • there is no way to select the e0 pin in the i/o mapping tab
    • the output from the configurator was:
    M558 P4 C"zprobe.in" H5 F120 T6000
    
    • while the expected output is
    M558 P5 C"zprobe.in" H5 F120 T6000
    

    probing did not work with the "p4" option

    I very much enjoy the rich and high-quality eco-system that has sprung up around duet, and would like to contribute, if only by bug reports for now. please let me know if this is indeed a bug, and if there is a better place to post it.

    Thanks!


  • administrators

    Thanks for reporting this! We'll get it fixed.


Log in to reply