heater fan slow down when start printing



  • Hi guys, a little introduction: this is Marco from Italy, I started making some modification on my Anycubic predator, placing first a Duet 3 board... some issue solved but, i've some headhake with one thing:

    When i turn on the printer the hotend fan is off, (I setup it to work in thermostatic mode at 50°C); when the hotend reach and pass that temperature, the fan start at 100%.... (good); issues come when I start printing (I use simplify 3D) because the fan slow down and I can't understand why. this (with wavy bed mesh) is making me Crazy.

    Somebody can help me understand?

    thank you all guys!

    Marco

    PS: this is my config File
    config.g


  • Moderator

    M106 P1 C"Ventola_Dis" S1 H2:1 T50

    Try changing the H2:1 to just H1

    If that doesn't work please post a sliced gcode file so we can see if S3D is changing anything.



  • Hi Phaedrux, thank you for fast answer.

    I've tried, unfortunately nothing change. 😢

    attached the last gcode i've made... I search for the M106, what i've not understood is how the board discriminate which fan start when it wrote M106 S255 when start the layer 2 on the example attached..

    03347fce-9278-443a-93ad-c318d5dfacc3-image.png

    to complete the information (probably it helps understand where I get wrong):

    ed7742c3-f095-4734-8e11-4492d247769f-image.png

    db63371e-46b9-452f-bab4-708065ae93b3-image.png

    (Ventola_Est = cooling for parts; Ventola_Dis= hotend dissipator cooling fan)

    d403f05e-0d67-4ecc-953d-95b2273fc1b3-image.png


  • Moderator

    I see the problem now

    M563 P0 S"Estrusore1" D0 H1 F0:1:2 ; define tool 0

    That should be just F0 and not F0:1:2

    The slicer doesn't know which fan it is controlling. It's the Duet that attaches a fan to a tool, and for you that should be Fan0 only.



  • Hi again Phaedrux, that's it! thank you!

    I put too much trust in my reprap firmware wizard 😰

    Thank you very much... now step by step I try solve other things on my config! 🚀


  • Moderator

    Are you saying that the config tool gave you that tool command with all 3 fans even though the screen shot only shows fan0 selected? Or was it edited afterwards?



  • I just understood what i've done, I opened the editor by the button on System folder:

    9a8c524d-ae44-408e-9bdd-fb1020a274b8-image.png

    i was thinking it was the actual configuration, but it's the first Json config i've made, probably the mistake come from there...

    sorry if i gave you some wrong info 😆


Log in to reply