Issue with Rpi/Duet3/7" Display in Full Screen



  • Aloha! I recently did the Sudo apt update, Sudo apt upgrade, BOSSA firmware update on my Duet3/RPi4 board to get everything up to 3.1.1. since the upgrade, my 7" Rpi screen functions correctly until the final Web Control display screen -- at which point I get grabbeled lines directly across the screen. If I exit full screen, everything is fine.
    Display worked correctly prior to update to 3.1.1, with the transition to full screen display showing correctly.

    I'm an Rpi and Duet novice, so I welcome suggestions on how to get the bootup sequence to correctly transition into Full Screen mode.



  • Did you update everything incl all the Rasbpian packages or just he DuetSoftwareFramework (DSF)?

    Suspect the issue is more related to xorg / chrome than DSF.



  • I followed the documentation, so sudo apt update and sudo apt upgrade... so does that only do DSF? or does it update the underlying Rpi as well? (as I said, novice)

    if xorg/chrome, how do I test or how do I fix?


  • Moderator

    @I_Jedi said in Issue with Rpi/Duet3/7" Display in Full Screen:

    sudo apt update and sudo apt upgrade

    That should include all of the underlying rpi software as well.



  • Yeah, that would update everything; is it the official Raspberry Pi 7" touch screen you're using?

    If not, please provide some specs on the screen.



  • @bearer Thank you for asking that. it is actually a Lebula 7" IPS 1024x600 screen I bought (new) off Amazon.

    https://www.amazon.com/dp/B07VNX4ZWY/ref=cm_sw_em_r_mt_dp_U_h9jiFbCV746EE



  • I just asked as that is the only sceen I have to test upgrading with. Presumably you're using an older version of the DuetPi image, maybe what was shipped with the board?

    I just tried a fresh version and it was up to date on the Duet software, but did have an xorg update available; however it worked fine after updating and rebooting on my 7" rPi screen. (Tested Pi 2B and 4B)

    xserver-common/testing 2:1.20.4-1+rpt2 all [upgradable from: 2:1.20.4-1+rpt1]
    xserver-xorg-core/testing 2:1.20.4-1+rpt2 armhf [upgradable from: 2:1.20.4-1+rpt1]
    

    If you have a spare SD card you could try downloading a new DuetPi image and seeing if that works before updating it, and if it breaks after updating it.

    just to be sure to isolate the cause you could do
    sudo apt update
    sudo apt upgrade duetsoftwareframework
    test if it still works then do
    sudo apt upgrade
    and see if it breaks after updating xorg again.



  • @bearer Thanks, I'll give that a try using the latest DuetPi image on a new card... the kicker is it worked a week ago flawlessly everytime. It wasn't until the sudo apt upgrade that thinks went wonky... so I know the screen work(ed) with the image I'm using but something during the upgrade broke that.



  • OK, I'm stumped... after four days and 30 reboots of not working and having to full screen out for some inexplicable reason the display is properly going into full screen mode. I didn't change anything... weird.... Not complaining, but cautiously optimistic that I had an anomalous loose wire somewhere that bumped back into place



  • So you didn't try another sd card?

    oh well, all that ends well and so.


Log in to reply