SOLVED: Curl Upload via Slicer ignores Folder on SDCard

  • Hi,


    Board: Duet 2 Maestro (2Maestro)
    Firmware: RepRapFirmware for Duet 2 Maestro 3.1.1 (2020-05-19b2)

    DWC: 3.1.1

    When I upload the sliced model via my slicer (Simplify3d 4.1.2) using curl, the file also lands cleanly on the Maestro and its SD card (#0).

    However, the specified folder "gcodes" is completely ignored and ends up in the root of the SD card.

    Basically this is not a problem, but it becomes too confusing for me.

    The following script is used for uploading to the duet:

    curl --data-binary "@[output_filepath]" "[output_filename].gcode&time=YYYY" 
    curl ""

    am I changing ?name=otto/[out....

    then nothing happens. The upload is not done at all. Even if I create the folder otto, nothing happens.

    Any ideas about this?

    Thanks and greetings

  • administrators

    If you don't specify a folder, it should upload to /gcodes automatically. So try:

    curl --data-binary "@[output_filepath]" "[output_filename].gcode&time=YYYY"

    I presume that S3D substitutes for [output_filename] and you are passing a date/time in ISO format where you have YYYY. Alternatively, you can omit the &time=YYYY part.

  • @dc42 said in Curl Upload via Slicer ignores Folder on SDCard:

    ata-binary "@[output_filepath]" "[output_filename].gcode&time=YYYY"

    Hi Dave,

    if i remove the gcodes in front of the Output-Filename the File not uploaded at all.

    Will try to dig with wireshark what happens.

  • Even if i do it from the command-Line (Windows) it still drop the File into the Root and if i remove gcodes in front of the output-Filename the file not uploaded at all.

    Will try it from a linux-system to double check if this is something which is coming from the Windows-Port of Curl

  • @MoS-tekknix said in Curl Upload via Slicer ignores Folder on SDCard:

    curl --data-binary "@[output_filepath]" "[output_filename].gcode&time=YYYY" 
    curl ""

    Thanks, in my case it works well.

    I have a Duet 2 Wifi motherboard with the same firmware version 3.1.1. Just the diference is that the name of the file appears like a date, but appears save in the g-code folder.


  • Thanks for getting back. I know that this has worked also on my Duet Wifi. But with the Maestro i'm struggling arround.

    This isn't a problem of the Curl-Build i'm using on Windows.

    Even on Linux, with Authentication and multiple tries i'm not able to upload it directly anywhere else as on the root.

    That's somehow odd. Maybe this deal together with the DWC 3.1.1? I'll try with a build of DWC 3.2 dev to verify.

  • administrators

    What's the name of the file you are trying to upload?

  • I am ... stupid ...

    As always, the problem sits between monitor and keyboard.

    After I built both the Legacy DWC 1 and the current Master Branch and also the DEV3.2 Branch of DWC, I had to get the SD card.

    And what had I seen? In the folder GCODES there was another folder GCODES ...

    So the files already ended up correctly in the folder GCODES, which I mistakenly considered as ROOT. Now that I have removed the DEV3.2 and have equipped my SD card with DWC 1.x and 3.1.1, and have created the GCODES folder anew, I can now proceed as desired...

    Silly me.

    It is just too warm at the moment (34°C)

    Greetings and thanks

Log in to reply