duet dead/not recognized by computer



  • So I am rather new to building 3d printers and have only dipped my toes into the world of software. I am mostly a hardware-focused person and just built my first printer from 8020. I then equipped it with a duet 2 wifi and had lost of fun changing the settings and working out problems with my design and firmware config. I had read the forms and was on my way to having a pretty nice printer.

    then a big problem started.

    I have recently changed my router due to some internet issues and found I needed to reconnect to the network. I went to connect the printer to my computer to send the new network settings to my printer via YAT and I found my computer didn't recognize it. I tried redoing the drivers and I even order a new cord that was rated for data (even though the old one I used was the one I originally set up the board with). Nothing worked and I continued to troubleshoot but found that the sd card was dead, when I tried putting another fresh card with all the firmware on it, it then bricked that card as well.

    So I am currently at the point where I unplugged everything off the board and tried to interface with it with just the USB plugged in and I think I was too late. I have no idea how this happened as all I did was plug the USB in to do some network changes. I think I narrowed the problem down to one of the PCB components being burned out and I am currently trying to find the part number and where to buy it.

    I attached some photos of the part in a question and I could really use some help in replacing it and maybe finding a source of the problem.

    No other parts on the board are discolored or burned in any way and only two of the blue LEDs right next to the USB light up when connected to my computer. I do have a hot air hug and solder reflow station I just need to know what parts to replace.

    IMG_20200731_164650~2.jpg https://imgur.com/a/ycYEGoQ



  • I also just remembered that I measured resistance on the parts in the photo and every lead on the component is shorted to ground. every pin has ohms to every other pin



  • start by removing the 3.3v regulator u2; if you don't still have a short from 3.3v to ground you can try applying an external 3.3v source (preferably current limtied to 2-300mA).

    if all good, get a new u2.

    (there are countless topic here with the same if you search a little)



  • and where would I find the part? I dont have software to open pcb schematics



  • theres pdfs alongside the kicad sources on github

    https://github.com/T3P3/Duet/tree/master/Duet2

    pick the correct revision ☝



  • btw cloned or genuine duet?

    when you say two blue leds, that is normally Vin and the wifi - the wifi wouldn't work with the chip in question damaged?

    (edit: if so, please ref https://duet3d.dozuki.com/Wiki/Hardware_Overview#Section_LED_indications and tell us which LEDs are on as the colour may well be misleading)


Log in to reply