DWC connection issues



  • I have just resurrected my BigBox which is driven by Duet 2 Ethernet after it being in hibernation for several years.
    I can connect to the Duet through YAT and have successfully enabled the network on 192.168.1.96 but when I enter 192.168.1.90 in Chrome to open DWC it returns the error Chrome refuses to connect, check internet and firewall which are of course ok. I get a similar error with duettest.local which reports 'duettest.local’s server IP address could not be found.'

    The firmware is 2.03 but I don't know what the DWC issue is, I do know that it is as it came with the Duet, I didn't update anything previously as there wasn't any updating needed at the time. I was planning on updating once I had everything running smoothly again. The only difference I have with my setup from when BigBox worked is that I am using a new laptop running Windows 10, the old laptop was on Win 8.

    Could anyone give me some clues as to why I can no longer connect to DWC? Thanks



  • @Kayjay said in DWC connection issues:

    192.168.1.96

    try specify unsecure http?

    http://192.168.1.96/

    could be modern browsers are trying to assume https which isn't (yet?) supported on the duet.

    if not try ping and check DWC files are present on the SD card in /www - but if it used to work, then the url might do the trick



  • You are a STAR my friend, it was the url. Thanks very much!!

    You are of course correct in saying that the files are still on the card, I did look just in case but they are there.


  • Moderator

    @Kayjay said in DWC connection issues:

    192.168.1.96 but when I enter 192.168.1.90

    Was it that you were using the wrong IP address?

    Ian



  • No, the IP was right, I just needed to add the http at the start. Have a look at bearers posting above, it will clarify for you.



  • eagle-eye ian just spotted you used two different ip's which could also explain the issue (but as the error was refusing connection odds are that was a typo)



  • Nope, the first IP is my network IP, ending 96 that's the IP I get when I connect my LAN as shown in YAT and my ISP's modem config page. The other IP (ending 90) is the one to connect to DWC.

    Your original diagnosis of needing to use http was the problem, all the IP's are correct. I connect to my network using 192.168.1.96 and to DWC using http://192.168.1.90

    Thanks for your help Bearer, it's saved a LOT of head scratching !
    Keith


Log in to reply