SOLVED Another post about thermistors reading 2000C



  • Hi, I'm trying to set up my newly purchase Duet 2 Wifi, and am stuck trying to get a temperature readings to work. Specifically, trying to get the bedtemp thermistor to read something other than 2000C (open circuit).

    I don't have the bed heater or extruder heater connected up yet (am simply testing and configuring each item as I connect it in order to familiarize with the Gcode settings). I'm just trying to get the bedheater to give me a value other than 2000C. I do have the steppers and endstops working.

    The bedtemp thermistor is from an Anycubic Predator heated bed:
    https://www.anycubic.com/products/ultrabase-hotbed-platform-380x380mm-for-predator
    It is a 100kohm resistor. I measured with a multimeter and found it to be 120kohm at present temperature.

    I have the following config.g file, running Firmware version 3:
    5c163480-5d29-44c5-8615-e7f018574418-image.png
    499d7192-0707-4bc5-8d9d-fdae5d5832cc-image.png

    My wire connections are as shown: e1f621ed-cd1f-4609-8fc2-6bc6600e0ee0-image.png

    63223708-05ec-42f3-b993-1e1b4bd238fe-image.png

    Here are the things I tried:

    • tried using a different thermistor (also 100kohm), but no difference (here is the thermistor i used):
    • tried using a different thermistor i had lying around that I measured the resistance of and found to be about 7kohm, and changed the gcode to T7000 to reflect this resistance value, no difference
    • tried plugging the different thermistors into the E0 thermistor connection, to see if it would register there, but no change.

    How can I make the E0 temperature show up in the Web HMI, it seems to always shows n/a ?
    Does the thermistor reading only work if the heater beds are on/active?
    Is there any other debugging I can do, could there be some fault in the board?

    Thanks



  • Hi,

    I only see the bed thermistor connection and it is not the right kind of connector so it might not actually be making the connection OR you might have connected the wrong wire since I see the correct connector lying there unconnected.

    Frederick



  • One update, I was previously running the extruder stepper (without heat) in cold extrusion mode, and as such had remove the H1 parameter from the M563 definition. I added that back in, and that fixed the n/a issue in the Extruder "current" field. But (of course) this now also says 2000C. I have two thermistors, both 100kohm, hooked up to the E0 and tempbed pins, and am getting 2000C for both of them now:

    0ad1ce99-34a5-4814-8e80-57dc7be37979-image.png



  • @fcwilt No, I think the connections are good. I took that photo after iterating with a few different thermistors. Here is the current setup, where I have the bedtemp termistor (with the right connector) hooked up to the bedtemp pin. I have a spare extruder thermistor (with the wrong connector, but it is still a good connection) hooked up to E0.

    144b8505-d233-42bd-a37f-b00a87969cee-image.png



  • I measured resistance across the two thermistors. One is 120kohm and the other is 107kohm.



  • Hi,

    OK now the picture looks better.

    And you are sure you are running firmware 3.1.1?

    Frederick



  • That must be it! I thought that I had firmware version 3 because it referred to that in the config.g file. However, when I send M115 to the machine, it seems I have an older firmware.

    a12ed507-cc31-4125-afd2-fee55b7e6f54-image.png

    Thank you!! I will try to update it and see how it goes.



  • @apairofcleats

    Just remember to follow the correct procedure.

    You must first update to 3.0.0 then to 3.1.1

    Upload Duet2and3Firmware-3.0.zip

    When asked let the update proceed.

    Upload Duet2and3Firmware-3.1.1.zip

    When asked let the update proceed.

    If all goes well you should be running firmware 3.1.1 and Duet Web Control (DWC) 3.1.1

    Frederick



  • Success! Upon updating to 3.0.0 both temp readings kicked in:

    c5512699-6286-4cea-a8ab-2249868db95e-image.png

    Will now update to 3.1.1 as you mentioned.

    Thanks again for you swift response!



  • Glad to see it is working for you.

    Frederick


Log in to reply