SOLVED M308 reports "sensor not ready" on thermistor



  • I have connected two additional thermistors to monitor the temperature of the Y-axis stepper motors.

    One lead of each thermistor is connected to the thermistor3/thermistor4-pin respectively on the expansion header and both second pins to the vssa-pin (on the expansion header as well).

    Both sensors read 2000.0° and using M308 i get:

    Sensor 4 (Y-Motor Left) type Thermistor using pin (e3temp,duex.e3temp,exp.thermistor4,exp.36), reading 2000.0, last error: sensor not ready, T:100000.0 B:4138.0 C:0.00e+0 R:4700.0 L:0 H:0
    

    This is how i configured the thermistors in my "config.g":

    ; Additional Temperature Sensors 
    M308 S3 P"exp.thermistor3" Y"thermistor" A"Y-Motor Right" T100000 B4138		; configure sensor 3 as thermistor on pin exp.thermistor3
    M308 S4 P"exp.thermistor4" Y"thermistor" A"Y-Motor Left" T100000 B4138		; configure sensor 4 as thermistor on pin exp.thermistor4
    

    I'm running Firmware 3.1.1 on my Duet 2 Wifi.

    As far as I understand there is no need to create a heater for additional thermistors any longer, correct? Do I need to create an input pin using the M950 command somehow?


  • administrators

    "last error: sensor not ready" is normal. When the thermistor is first configured, it returns "not ready" until enough ADC readings have been taken.

    To use a thermistor pin on the expansion header, you need to add a resistor between the pin and the VREF on on the expansion header. 4K7 is the usual value.



  • Thanks, adding the 4.7k resistors solved it!


Log in to reply