SD Card Problem



  • I've been using my Duet Maestro in my Lowrider CNC build and its been working fine, previously came out of my Delta printer where it was also working fine. Today I tried to log in to the webpage and couldn't, so I went and looked at the Maestro and neither of the ethernet lights were on, so I figured it was a network issue. After ruling out network issues I decided to connect to the Duet via USB. I was able to enable the network but then when I tried to access the webpage I got the following:

    Your Duet rejected the HTTP request: page not found
    Check that the SD card is mounted and has the correct files in its /www folder

    After that and looking on the forums for some clues I found that I should run M503 and M39 in YAT. For M503 I got an OK response, but for M39 I got "Error: No SD card mounted in slot 0".

    Any idea whats going on? Do I just need to reformat the SD card? I plugged it into my laptop (Mac) and it tells me the card needs to be reformatted before it can be read...which I'm reluctant to do, as I don't have a backup.



  • Tried a second SD card with a fresh folder structure and it works. So I guess now the question is, why did my SD card get messed up?




  • Moderator

    SD cards do fail unfortunately. I don't know if the workload placed on them by a duet is any harder than others, but they do get "worn" as the flash cells are repeatedly written to. They can only survive so many write cycles.

    It seems like you've already found and solved the issue, but in case someone else finds the thread here's some tests you can do to check the card.
    https://duet3d.dozuki.com/Wiki/SD_Card#Section_Troubleshooting_SD_Card_issues



  • I had a spate of even brand new cards failing in a very very short time down, I posted about this here before and some recommendations pointed me in the direction of scandisk industrial cards, which seem to be holding up very well so far


Log in to reply