Ethernet not working



  • Duet2 Ethernet controller will not communicate via ethernet.
    CONFIG below. There are no leds lit on the RJ45 ethernet plug which I am suspicious.

    Thanks

    Jeff

    M122
    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 2.05.1 running on Duet Ethernet 1.02 or later
    Board ID: 08DJM-9178L-L2MSD-6JKDD-3SJ6K-98H2R
    Used output buffers: 1 of 24 (1 max)
    === RTOS ===
    Static ram: 25712
    Dynamic ram: 92460 of which 164 recycled
    Exception stack ram used: 256
    Never used ram: 12480
    Tasks: NETWORK(ready,1980) HEAT(blocked,912) MAIN(running,3824) IDLE(ready,160)
    Owned mutexes:
    === Platform ===
    Last reset 00:01:10 ago, cause: reset button or watchdog
    Last software reset details not available
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms, max retries 0
    MCU temperature: min 35.4, current 36.6, max 36.8
    Supply voltage: min 1.6, current 1.7, max 1.7, under voltage events: 0, over voltage events: 0, power good: no
    Driver 0: ok, SG min/max not available
    Driver 1: ok, SG min/max not available
    Driver 2: ok, SG min/max not available
    Driver 3: ok, SG min/max not available
    Driver 4: ok, SG min/max not available
    Date/time: 1970-01-01 00:00:00
    Cache data hit count 118742677
    Slowest loop: 0.18ms; fastest: 0.05ms
    I2C nak errors 0, send timeouts 0, receive timeouts 0, finishTimeouts 0, resets 0
    === Move ===
    Hiccups: 0, FreeDm: 160, MinFreeDm: 160, MaxWait: 0ms
    Bed compensation in use: none, comp offset 0.000
    === DDARing ===
    Scheduled moves: 0, completed moves: 0, StepErrors: 0, LaErrors: 0, Underruns: 0, 0
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    Heater 1 is on, I-accum = 0.0
    === GCodes ===
    Segments left: 0
    Stack records: 1 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is ready with "M122" in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 0.24ms; fastest: 0.01ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 0 of 8
    Interface state 2, link down
    ok
    M115
    FIRMWARE_NAME: RepRapFirmware for Duet 2 WiFi/Ethernet FIRMWARE_VERSION: 2.05.1 ELECTRONICS: Duet Ethernet 1.02 or later FIRMWARE_DATE: 2020-02-09b1
    ok
    m552 S1 P192.168.125.100
    ok
    m552
    Network is enabled, configured IP address: 192.168.125.100, actual IP address: 192.168.125.100
    ok
    M586 P0 S1
    HTTP is enabled on port 80
    ok
    Network running, IP address = 192.168.125.100


  • Moderator

    @JKonopacki what is the Duet’s Ethernet connected to? A network router, or direct to a PC? If it’s direct to a PC, there are additional setup steps.

    A good Ethernet cable needs to be connected, and the connection at the other end turned on, before turning on the Duet.

    Ian



  • Ian, Thanks for the reply. I was successful getting the controller on the network, however as I do not know the typical behavior Im not confident with the results. I tried using YAT and sending the 552, 553, and 554 codes both as a DHCP client and fixed IP which did not work. After sleeping on the problem, I edited the config file with a USB to SD converter. I tried the DHCP client P0.0.0.0 first which did not work. When I use the fixed or assigned IP the unit connects although it takes roughly 15 minutes before It connects (responds to ping). The device does not show up as a DHCP lease on my Ubiquiti router but I can ping it and connect through http: Strange.



  • @JKonopacki said in Ethernet not working:

    it takes roughly 15 minutes before It connects

    can you try fixing the link settings for the port in question to 10mbit full duplex instead of auto negotiate and see if it makes a difference?

    i've only tested duet on unifi switch/ap not their routers so could be different compatability



  • Bearer,
    I assume you mean restricting the port on the router to 10mbit vs auto or on the Duet?

    Jeff


  • Moderator

    It would have to be on the router/switch



  • @JKonopacki said in Ethernet not working:

    I assume you mean restricting the port on the router to 10mbit

    yes, once in a blue moon someone have issues with auto negotiation, but the duet does not have settings for controlling it so it has to be the router/switch if possible. the very long timeout may indicate this is the issue for you so worth a try imho


  • Moderator

    If that doesn't work, do you have another router/switch just to test with?

    Where and when was the Duet purchased?



  • OK, I set up an old Mikrotik router and the controller connects instantly. Not ideal with the second router as I will need to create a route to this subnet, but workable. Thanks for the help.

    Jeff


  • Moderator

    What brand and model of router was it not playing nicely with?



  • Ubiquiti Dream Pro with SFP+ to a Dell 1Gbit switch (plugged into switch). If I plug into a Netgear 10/100Mbit switch connected to the Ubiquiti router it works fine.

    Jeff


  • Moderator

    Hmm, so I wonder if it's the 10/100 part that is solving it, or if it just doesn't like something else about the ubiquity.



  • Hmm, so I wonder if it's the 10/100 part that is solving it, or if it just doesn't like something else about the ubiquity.

    its usually not a question of 10 or 100 mbit, but the negotiation of it. I usually suggest 10 mbit as it will be faster than the duet's SD interface and more reliable if there is a compounding issue with less than ideal cabling.

    Ubiquiti Dream Pro with SFP+ to a Dell 1Gbit switch (plugged into switch)

    so the device is connected to the Dell switch or the dream machine? if the switch that is where the compatibility issue would be most likely, and where disabling auto-negotiation might help.


Log in to reply