Laser Filament Sensor



  • I have installed a laser filament monitor with indirect read on a carbon rod. Details of setup are below.

    Board: Duet WiFi 1.02 or later (duetwifi102)
    Firmware: RepRapFirmware for Duet 2 WiFi/Ethernet 3.0 (2020-01-03b3)
    Duet WiFi Server Version: 1.23

    M591 D0 P5 S1 C"E0_Stop" R0:250 E5.0

    m591 d0
    Duet3D laser filament monitor v2 on pin e0stop, enabled, allow 0% to 250%, check every 5.0mm, version 2, quality 222, brightness 255, shutter 64, measured min 0% avg 111% max 179% over 102.0mm

    I have looked about everywhere I can think to look but still have several questions.

    1. I am getting - minimum vales especially on the first layer. Is there any way to have the sensor ignor the first few layers? Obviously I am not going to start a print that will run out in 2 layers. However, if my bed is a bit too tight it causes a filament flow problem and the sensor shuts down the print.

    2. I can find no documentation telling me what quality, brightness, and shutter are telling me.

    3. R value... If my esteps are set to 100 and my R value is 0 to 140 should I expect the sensor to accept any movement from 0 to 140 mm/min? If not, what is that range telling me?

    4. I also read that - R values put the board in calibration mode. Is that still the case? Is that why when I set the R value to -100 to compensate for the first layer issue it runs a few mm then pauses the print?

    Any light you can shed on this would be appreciated. Thanks


  • administrators

    @JADoglio said in Laser Filament Sensor:

    I am getting - minimum vales especially on the first layer. Is there any way to have the sensor ignor the first few layers? Obviously I am not going to start a print that will run out in 2 layers. However, if my bed is a bit too tight it causes a filament flow problem and the sensor shuts down the print.

    You could change the sensor from disables to enabled on layer 3? some slicers allow for commands to be inserted on layer change. That said, if you are laying down less filament on the first layers than what the gcode is commanding your extruder to extrude then there is a problem (caused by the high extrusion pressures I assume?). Either the extruder is skipping steps, or filament is slipping, or filament is grinding. all of those issues are what the filament monitor is designed to detect so its preferable to fix the issue rather than ignore it by disabling monitoring.

    I can find no documentation telling me what quality, brightness, and shutter are telling me.

    I have updated the documentation to describe there : https://duet3d.dozuki.com/Wiki/Duet3dFilamentMonitor_LaserVersion#Section_Reported_Information

    R value... If my esteps are set to 100 and my R value is 0 to 140 should I expect the sensor to accept any movement from 0 to 140 mm/min? If not, what is that range telling me?

    R is independent of esteps. it is the window of acceptable movement xx% low, yyy% high, outside of which the print is paused due to filament movement out of range.

    I also read that - R values put the board in calibration mode. Is that still the case? Is that why when I set the R value to -100 to compensate for the first layer issue it runs a few mm then pauses the print?

    negative values of R for calibration was a feature of very early firmware- it is not longer used or required. The monitor accumulates calibration data when running and that information is reported back when sending M591 Dn See here for more information:

    https://duet3d.dozuki.com/Wiki/Duet3dFilamentMonitor_LaserVersion#Section_Calibration



  • @T3P3Tony

    Thanks Tony the links were very helpful. I agree fixing the hot end clearance issue on the first layer is a better solution. My problem is that when I am doing a print that takes up a large part of the surface area on the bed 90% of the bed will be at the right clearance but the 10% is not due to the bed not being perfectly flat. So, correcting the problem sounds easier than it might be. Which means if I want to use the sensor I have to stay and monitor the entire first layer to restart the print if it pauses at these spots. After the first layer is down the problem no longer exists and the sensor will only pause the print when it should.

    Based on your comments on calibration should I be able to set R minimum to a negative value? It seems not, because when I do that the M591 command ignores the R value and substitutes 0-160 for the R values. Is that what it should do?

    These are the typical numbers I am getting. Once I get past any first layer issues this is a typical D591 result. It seems really good to me, would that be correct?

    m591 d0
    Duet3D laser filament monitor v2 on pin e0stop, enabled, allow 0% to 250%, check every 5.0mm, version 2, quality 222, brightness 255, shutter 77, measured min 155% avg 165% max 176% over 80.9mm

    Thanks again for any help here.


Log in to reply