Mesh Bed looks like this dualWave... no matter what



  • And the best of it... it does nothing... my printhead collides on the areas mapped green, or the filament gets round on the other areas. so I can't print anything...
    I updated to duet3d (2.05) and webcontrol 3.11...

    After G32 --> delta calibration with 16 points and factor9... I generated this:

    M665 L397.303:397.303:397.303 R156.932 H539.918 B175.0 X-0.014 Y-0.248 Z0.000
    M666 X-0.503 Y0.886 Z-0.383 A0.77 B-0.18
    

    I do run a G28 (home with Z axis uses as probe), so I have after homing the probing of BL-touch to exactly have my Z height, which is really Z=0 with a piece of paper between.

    Then I save it with M500. Reboot the machine and load the config-override.g with all values stated above.

    Now I create the Hightmap which looks like this:
    3DMesh.png
    The fully thing about this is, I totally rebuild the machine with all bearings and belts, because I thought there would be a backlash problem... but it was not... after rebuild, the map looks even wavier than before.

    If I load the map with M29 S1. it seems not doing anything since the head crashes on the heights and builds up round filament because of too much distance and to less extrusion.

    HELP, or at least one little hint what else to try...

    Thanks to all who read this...



  • have a look at this
    http://boim.com/DeltaUtil/CalDoc/Calibration.html

    did you start out with 9 factor? or did you adjust to it?

    where is your probe? if its offset that could be a problem if you have effector tilt.

    post your config.



  • I looked at this Calibration Error page, found a single wave with towers moved out so I rebuild the machine ... yes this site was responsible for me rebuilding the entire machine, but really it did not change anything, but I was happy to resolve a couple of problems like loose pulleys on steppers and loosened belts on the carriages. (But remember, I never actually did a productive print at all, only test prints. The machine never evolved to a productive environment... highly experimental only... maybe 50h of test printing)
    The mesh looked much more like a cliffy waved surface. After the rebuild it looks really homogeneously nice double wavy.

    I rewrote the config removed all loads and reloads of meshes in the config and from the homing, so if the machine starts up only delta calibration from the config-override is loaded.

    I did I think all factors from 6 to nine... nothing really change something.

    Yes I have a probe offset, but how does this come into play if I do a mesh?
    Even with a tilt, isn'i it supposed it to be constant? on all points, since the Effector does not rotate?

    I went through all config tutorials for delta and the result is only a beautiful double wave, which does not compensate even if I load the mesh...

    I used this for creating the bed.g: http://escher3d.com/pages/wizards/wizardbed.php

    config.g:

    ; Communication and general
    M111 S0                             		; Debug off
    M550 PMyPrinter			; Machine name and Netbios name (can be anything you like) addresses, so change the last digits
    M540 P0x**:0x**:0x**:0x**:0x**:0x**		; MAC Address
    
    ;*** Networking - Enable for both WiFi and Ethernet boards.
    M552 S1						; Turn network on
    
    ;*** Ethernet networking: Adjust the IP address and gateway in the following 2 lines to suit your network
    M552 P192.168.0.85				; (0 = DHCP)
    M554 P192.168.0.1				; Gateway
    M553 P255.255.255.0				; Netmask
    
    ; General preferences
    M111 S1 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M555 P1 							; Set firmware compatibility to look like RepRapFirmare
    M665 R157 L398 B175 H540			; set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0						; put your endstop adjustments here, or let auto calibration find them
    M208 Z0 S1 							; Set minimum Z
    
    ; Endstops
    M574 X2 Y2 Z2 S1 ; Define active high microswitches
    
    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes backwards
    M350 E128 I0 ; Configure microstepping without interpolation
    M350 X256 Y256 Z256 I1 ; Configure microstepping with interpolation
    M92 X1280 Y1280 Z1280 E1100 ; Set steps per mm
    M566 X1200 Y1200 Z1200 E3000 ; Set maximum instantaneous speed changes (mm/min)
    M203 X40000 Y40000 Z40000 E3000 ; Set maximum speeds (mm/min)
    M201 X1000 Y1000 Z1000 E1500 ; Set accelerations (mm/s^2)
    M906 X1800 Y1800 Z1800 E1500 I50 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout
    
    ; Heaters
    M143 S300 					; Set maximum heater temperature to 300C for Hotend
    M301 H0 S1.00 P10 I0.1 D200 T0.4 W180 B30 	; Use PID on bed heater (may require further tuning)
    M305 P0 T100000 B4607 C8.950070e-8 R4700 	; Set thermistor + ADC parameters for heater 0
    M305 P1 T100000 B4138 C0 R4700 			; Set thermistor + ADC parameters for heater 1
    M307 H7 A-1 C-1 D-1 				; Disable the 7th Heater to free up PWM channel 5 on the Duex board.
    ;M570 S180					; Hot end may be a little slow to heat up so allow it 180 seconds
    
    ; Fan Modes
    M106 P0 T40 H1					; Turn on Fan0 if Heater Temperature is above 40°C
    ;M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S0 I0 F500 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    
    ; Tools
    M563 P0 D0 H1 F1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    
    ; BL-Touch
    M558 P9 H5 X0 Y0 Z1 F150 T6000    	; Set Z probe type/mode 5. Not using on XY, but using it on Z.
    G31 P25 X18 Y-10 Z0.7	        	; Set Z probe trigger value, offset and trigger height
    M557 R150 S15                       ; define mesh grid
    
    ; Miscellaneous
    M144 S0;
    M140 S0;
    M575 P1 S1 B57600          	; enable support for PanelDue
    M501  					; Load saved parameters from non-volatile memory
    T0						; Select active hotend
    G4 P5000 				; pause workaround for the rrf/paneldue bug
    T0						; select first hot end
    G28						; Home it
    

    bed.g:

    ; bed.g file for RepRapFirmware, generated by Escher3D calculator
    ; 16 points, 7 factors, probing radius: 150, probe offset (18, -10)
    M98 Pdeployprobe.g
    G30 P0 X0.00 Y150.00 Z-99999 H0
    G30 P1 X93.17 Y111.03 Z-99999 H0
    G30 P2 X133.09 Y23.47 Z-99999 H0
    G30 P3 X114.23 Y-65.95 Z-99999 H0
    G30 P4 X46.33 Y-127.29 Z-99999 H0
    G30 P5 X-49.78 Y-136.77 Z-99999 H0
    G30 P6 X-129.90 Y-75.00 Z-99999 H0
    G30 P7 X-147.72 Y26.05 Z-99999 H0
    G30 P8 X-96.42 Y114.91 Z-99999 H0
    G30 P9 X0.00 Y75.00 Z-99999 H0
    G30 P10 X55.74 Y32.18 Z-99999 H0
    G30 P11 X50.96 Y-29.42 Z-99999 H0
    G30 P12 X0.00 Y-64.74 Z-99999 H0
    G30 P13 X-64.95 Y-37.50 Z-99999 H0
    G30 P14 X-64.95 Y37.50 Z-99999 H0
    G30 P15 X0 Y0 Z-99999 S9
    M98 Pretractprobe.g
    

    homedelta.g:

    ; called to home all towers on a delta printer
    ;
    ; generated by RepRapFirmware Configuration Tool on Mon May 22 2017 22:56:20 GMT-0400 (Eastern Daylight Time)
    
    ; Reset BL-Touch
    M280 P7 S160 I1            ; Clear probe
    
    ; Use relative positioning
    G91
    
    ; Move all towers to the high end stopping at the endstops (first pass)
    G1 X750 Y750 Z750 F3500 S1
    
    ; Go down a few mm
    G1 X-5 Y-5 Z-5 F2500 S2
    
    ; Move all towers up once more (second pass)
    G1 X50 Y50 Z50 F500 S1
    
    ; Go down a few mm
    G1 X-2.5 Y-2.5 Z-2.5 F2500 S2
    
    ; Move all towers up once more (third pass)
    G1 X50 Y50 Z50 F100 S1
    
    ; Move down a few mm so that the nozzle can be centred
    G1 Z-24.56 F5000
    
    ; Switch back to absolute positioning and go to the centre
    G90
    G1 X-18 Y10 Z25 F10000  
    G30						; lower head, stop when probe triggered and set Z to trigger height
    G4 P500					; Pause
    G1 X0Y0Z51				; Move Nozzle to Bed middle
    

    retractprobe.g:

    M280 P7 S90 I1
    

    deployprobe.g:

    M280 P7 S160 I1	; clear and reset BL touch
    M280 P7 S10 I1	; PIN down
    

    config-override.g:

    ; config-override.g file generated in response to M500 at 2020-08-31 14:50
    ; This is a system-generated file - do not edit
    ; Delta parameters
    M665 L397.303:397.303:397.303 R156.932 H539.918 B175.0 X-0.014 Y-0.248 Z0.000
    M666 X-0.503 Y0.886 Z-0.383 A0.77 B-0.18
    ; Heater model parameters
    M307 H0 A90.0 C700.0 D10.0 S1.00 V0.0 B1
    M301 H0 P10.0 I0.100 D200.0
    M307 H1 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H2 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H3 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H4 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H5 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H6 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    G10 L2 P1 X0.00 Y0.00 Z0.00
    G10 L2 P2 X0.00 Y0.00 Z0.00
    G10 L2 P3 X0.00 Y0.00 Z0.00
    G10 L2 P4 X0.00 Y0.00 Z0.00
    G10 L2 P5 X0.00 Y0.00 Z0.00
    G10 L2 P6 X0.00 Y0.00 Z0.00
    G10 L2 P7 X0.00 Y0.00 Z0.00
    G10 L2 P8 X0.00 Y0.00 Z0.00
    G10 L2 P9 X0.00 Y0.00 Z0.00
    


  • @duetino said in Mesh Bed looks like this dualWave... no matter what:

    M350 X256 Y256 Z256 I1 ; Configure microstepping with interpolation

    First this is not supported on a duet wifi.
    Second this is a bad idea on a delta. it will overload the cpu.

    unless you have a very specific reason you should go with x16 with interpolation.

    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    unrelated, but your thermistor setting is wrong.

    dc42 calls that "crinkle crisp"
    https://forum.duet3d.com/topic/11089/problem-with-bed-leveling?_=1598890178644

    on my delta i also had problems with my first layer when using a probe that was offset.
    in the end i went with this https://www.aliexpress.com/item/32838312776.html and it works very well.


  • Moderator

    @duetino if you suspect errors due to the offset probe, try running a calibration and then mesh compensation with M558 P0. Yes, that’s manual probe, but measuring from the nozzle tip will give an accurate reading, especially if your nozzle hangs down a long way below your effector. It’ll take a while, but you’ll see the true results ‘at the nozzle‘. Don’t forget to set G31 offsets to 0.

    Offset probes on deltas are just not great. Calibrating deltas is hard enough, adding an extra variable is unwanted. Get some kind of piezo or contact probe.

    Ian



  • This post is deleted!

Log in to reply