Web Control Look and feel



  • Hi All,

    i am trying to get my duet web control working correctly and i have a few Qs im hope you maybe abe to help with.

    1. When trying to use google chrome it wont let me connect to the board for some reason. Firefox seems to be ok (other than other issues which are below) Chrome is my go to browser so if there is a way to get that working i would much appreciate it.

    2. When i open it with my IP address. i get this screen which isnt right when comparing with youtube channel for how tos. please see below image where you can see the axis alignment/movement button are all clustered together as one example of it looking oddly, does anyone know how to fix this?

    c84226eb-a780-476b-912b-dc74b598393b-image.png

    1. finally when just trying to practice and play with the settings i have noticed that the web control doesnt have live feedback and i have to connect and disconnect to show the progress, the example i tested this by turning the heated bed on but to see what temperature it got to i had to disconnect and reconnect. Is this normal? and if so is there a way to get live feedback?

    I hope you are able to help.
    Kind Regards
    J


  • Moderator

    I think your /www folder contents are corrupt or incomplete or don't match the firmware version flashed to the board.

    What firmware version are you running? M115 to find out if it doesn't display at all properly in the DWC.

    Your image of the DWC looks like a very old version.



  • FIRMWARE_NAME: RepRapFirmware for Duet 2 WiFi/Ethernet FIRMWARE_VERSION: 2.03beta3 ELECTRONICS: Duet WiFi 1.02 or later FIRMWARE_DATE: 2019-03-25b6

    This is what i get when i use code M115

    Is it wrong?



  • @PR1OR said in Web Control Look and feel:

    : 2.03beta3

    beta firmware are not supported after the final release. the current firmware version for rrf2 is 2.05.1 and for rrf3 3.1.1



  • @Veti So i a proper novice with this, are you able to send me a link?

    to upload this should i do it via terminal (mac) or can i do it through the web control?



  • here is documentation page about updating the firmware

    https://duet3d.dozuki.com/Wiki/Installing_and_Updating_Firmware



  • @Veti Thanks for this!!

    I know how stupid this sounds but im still unsure on what to actually download. Is it the Duet2and3Firmware-3.1.1.zip?

    Im getting alittle confused with what i need to actually do from that page.

    I take it that i put the SD card into the mac delete everything and replace it. before i do this are you able to confirm? sorry about this





  • @PR1OR I'd recommend following the guide Bearer linked, but to be clear you don't need to take out the SD card from the Duet, or wipe any files from it. It is simply a case of uploading the files via the web interface 🙂



  • @engikeneer so for some reason i cant connect any more its connected to the wifi and i can connect to the web control IP but can connect from within the web control.

    So ideally i would do it from taking the SD card out i will take look at Bearer link now so thank you for that!!



  • see Fallback procedure #2 in the guide



  • @engikeneer said in Web Control Look and feel:

    ia the web in

    So i now have myself back on the web control, and i believe i have put 3.1.0 then upgraded it to 3.1.1 however on the web control page it has N/A for both Firmware Name and Firmware Version

    i also still have the same issue in point 2

    Any Ideas?



  • @PR1OR said in Web Control Look and feel:

    i have put 3.1.0 then upgraded it to 3.1.1

    you have to upgrade to 3.0 then 3.1.1 not 3.1.0



  • thanks for this!! so i now have the web control telling me the firmware name and version. But its still 2.03beta3 ive tried uploading the Duet2CombinedFirmware.bin and the Duet2and3Firmware-3.0.zip and and they appear to upload correctly (however it doesnt ask me ' Duet Web Control will ask you whether you want to install the new firmware. If you are only updating the main firmware, answer Yes. If you are updating WiFi firmware as well, answer No so that you can upload the new WiFi firmware too.')

    sorry to keep going on about this. im very out of my depth



  • go to the console tab and see what it says



  • @Veti So using the G code console tab i put m115 and its still says 2.03beta3 :s



  • @PR1OR

    whats the output of M997 S0



  • Might be worth seeing if you can update to 2.05.1 first?

    (Doesn't appear to be any changes to the iap4e.bin file between 2.03 and 2.05 - but could be its missing?)



  • Hi All,

    Thanks for all your responses, i am slowly slowly getting there.

    Still not uploading any new firmware though.

    I have done a screen recording to see if you im doing something obviously wrong.

    any help is massively appreciated

    https://youtu.be/XmnR6JfA2Z4



  • @Veti said in Web Control Look and feel:

    M997 S0

    so it says this.

    Error: M997: In-application programming binary "iap4e.bin" not found

    where is the iap4e.bin? i cant find it within the firmware folder that was downloaded from the links above



  • @PR1OR said in Web Control Look and feel:

    where is the iap4e.bin? i cant find it within the firmware folder that was downloaded from the links above

    @bearer said in Web Control Look and feel:

    Might be worth seeing if you can update to 2.05.1 first?

    (Doesn't appear to be any changes to the iap4e.bin file between 2.03 and 2.05 - but could be its missing?)

    62e15fde-0ae8-4575-8434-034f0b81610d-image.png



  • @bearer Thanks for this!!! its worked so im not on 2.05.1

    So im am now trying to advance to 3.0 but its not updating again. Could this be because iap4e.bin doesnt exist in the 3.0 zip?

    If so should i put it into the folder re-zip it and upload that way?



  • @PR1OR said in Web Control Look and feel:

    So im am now trying to advance to 3.0 but its not updating again. Could this be because iap4e.bin doesnt exist in the 3.0 zip?

    you should be good for 3.0 after 2.05.1 - try running M997 again and see if it gives you a different error.

    (2.05.1 uses the iap4e.bin that you got from Duet2Firmware-2.05.1.zip - which will be renamed to Duet2CombinedIAP.bin in 3.0 so therefore its missin in the 3.0 zip file)

    ((and to further complicate it, Duet2CombinedIAP.bin changed between 3.0 and 3.1 which is why you have to update to 3.0 first, then 3.1))



  • @bearer So i ran m997 and the board (certainly the wifi LED) turned off and on again. However the g code log hasnt updated with anything is that right?

    Also, so because the iap4e.bin has changed its name. should i rename Duet2CombinedIAP.bin?



  • So i ran m997 and the board (certainly the wifi LED) turned off and on again. However the g code log hasnt updated with anything is that right?

    yeah think thats about right, if you had the Duet2CombinedFirmware.bin from 3.0 and iap4e.bin from 2.05.1 it should have worked. run M115 to see what the current version is.

    Also, so because the iap4e.bin has changed its name. should i rename Duet2CombinedIAP.bin?

    no, Duet2and3Firmware-3.0.zip will supply the new IAP file.


Log in to reply